МИНИСТЕРСТВО ЗДРАВООХРАНЕНИЯ РЕСПУБЛИКИ БЕЛАРУСЬ
БЕЛОРУССКИЙ ГОСУДАРСТВЕННЫЙ МЕДИЦИНСКИЙ УНИВЕРСИТЕТ
КАФЕДРА МЕДИЦИНСКОЙ И БИОЛОГИЧЕСКОЙ ФИЗИКИ

М. А. ШЕЛАМОВА, В. Г. ЛЕЩЕНКО

ОРГАНИЗАЦИЯ ВЫЧИСЛЕНИЙ
И ГРАФИЧЕСКОЕ ПРЕДСТАВЛЕНИЕ
МЕДИКО-БИОЛОГИЧЕСКОЙ ИНФОРМАЦИИ
С ИСПОЛЬЗОВАНИЕМ ПРОГРАММЫ EXCEL

ORGANIZATION OF CALCULATION
AND GRAPHICAL REPRESENTATION
OF BIOMEDICAL DATA IN EXCEL

Учебно-методическое пособие

Минск БГМУ 2017
Шеламова, М. А.


Содержится описание основных возможностей электронных таблиц Excel, последующая реализация которых показана на многочисленных профессионально-ориентированных практических заданиях.

Предназначено для студентов 1–6-го курсов всех факультетов, обучающихся на английском языке.

УДК 577.3:004(075.8)-054.6
ББК 32.97я73

Учебное издание

Шеламова Марина Алексеевна
Лещенко Вячеслав Григорьевич

ОРГАНИЗАЦИЯ ВЫЧИСЛЕНИЙ И ГРАФИЧЕСКОЕ ПРЕДСТАВЛЕНИЕ МЕДИКО-БИОЛОГИЧЕСКОЙ ИНФОРМАЦИИ С ИСПОЛЬЗОВАНИЕМ ПРОГРАММЫ EXCEL

ORGANIZATION OF CALCULATION AND GRAPHICAL REPRESENTATION OF BIOMEDICAL DATA IN EXCEL

Учебно-методическое пособие
На английском языке

Ответственный за выпуск М. В. Гольцев
Переводчик Ю. И. Шеламова
Компьютерная верстка Н. М. Федорцовой


Издатель и полиграфическое исполнение: учреждение образования «Белорусский государственный медицинский университет».

Свидетельство о государственной регистрации издателя, изготовителя, распространителя печатных изданий № 1/187 от 18.02.2014.
Ул. Ленинградская, 6, 220006, Минск.


© Шеламова М. А., Лещенко В. Г., 2017
© УО «Белорусский государственный медицинский университет», 2017
INTRODUCTION

Microsoft Office Excel is an effective tool for processing of numerical data represented in the form of a spreadsheet. It enables to perform mathematical, financial and statistical calculations, draw up tabulated reports, display numerical data in the form of charts and graphs, and create document templates.

The study guide covers the following issues:

– creating, formatting and editing of spreadsheets containing various types of biomedical data;

– creating, formatting and editing of embedded charts, plotting of graphs illustrating values dependence;

– creating of spreadsheet templates and their use for preparation of standard medical documents.

Main objectives of the study guide:

1. Introduce features and functional capabilities of Excel.
2. Develop skills in filling of spreadsheets with data and its editing.
3. Develop skills in creating, editing and practical application of formulas.
4. Introduce the methods of graphic representation of biomedical data.

The authors of the study guide aimed to provide all minimum knowledge required for successful use of Excel during studies and at work in a concise and easy-to-understand manner.
BASIC FUNCTIONALITIES OF THE EXCEL SPREADSHEETS

Main issues:
1. Structure of the program window. Worksheet structure.
2. Formats of data in cells.
3. Workbook creating and saving.
4. Data input and editing.
5. Formulas input, use and editing. Cell reference.
7. Plotting of charts.

The Excel spreadsheets are intended for data storage and processing, automated formulas calculation and graphical representation of the results.

An electronic spreadsheet is a computer equivalent of a regular table in the cells of which you can record various types of data, such as text, dates, formulas, numbers.

STRUCTURE OF THE EXCEL PROGRAM WINDOW

When Excel starts, it creates the working area of a spreadsheet and the control panel. The control panel typically includes the menu bar, ribbon, formula bar and status bar. The layout of these areas on the screen can be changed by the user.

Along the upper border of the Excel window (fig. 1) there is the **Title bar**, which displays the name of the program and the name of the current file. In the right part of the title bar there are three window size control buttons, while in its left part there is the **Office** icon that opens the application menu. Below the title bar there are the **Menu bar** and the **Ribbon**. The menu bar is divided into separate tabs with their own Ribbon activated by clicking it with the left mouse button. In the right corner of the menu bar there are the workbook size control buttons and the Microsoft Office Help button.

The **Ribbon** of each tab contains buttons (icons) used for quick activation of certain menu commands and functions of the program.

The **Formula Bar** displays the cell’s data. It is used to enter or edit the content of the current cell. When working with formulas, the formula bar displays not the result of the calculation, but the formula or function contained in the current cell. Therefore, the formula bar is useful for viewing and editing the contents of a cell, whether it is a value, text, formula or function.

Under the working area of a worksheet, there is the **Status bar** that displays the messages on possible actions at the moment.
The working area of the worksheet consists of rows and columns, which have their specific names. Row names are represented by their numbers. Column names are the letters of the Latin alphabet, first from A to Z, then from AA to AZ, BA to BZ, and so on. The maximum number of columns and rows is determined by the peculiarities of a particular spreadsheet and memory capacity of a computer (e.g.: 256 columns and 65,536 rows).

The elements situated at the intersection of rows and columns are called the cells. Each cell has a unique address, which consists of the column name (letter) and the row name (number). To specify a cell address in the formulas the references are used (e.g., A2 or C4). The current cell is the cell, which is currently selected with the cursor.

WAYS OF MOVING ACROSS THE WORKSHEET

At the right border and at the bottom of the window there are vertical and horizontal scroll bars. The first one is intended for vertical alignment of the worksheet, while the second one — for horizontal alignment of the worksheet. You may also move across the worksheet using the Page Up and Page Down keys of the keyboard.

Fig. 1. Structure of the Excel window
TYPES OF DATA IN SPREADSHEET CELLS

Each cell may contain different types of data, as well as formulas and functions.

Text data include up to 255 alphanumeric characters, punctuation marks, etc.

Numeric data can not contain any alphabetic or special characters, as it is used for mathematical operations. The only exception is the decimal point or comma and the number sign (e.g. –87,6).

Dates are the data type that has the following functions: addition of a number of days to a date (counting dates back and forward), calculation of the difference between two dates (period duration).

Formulas begin with the equality sign (=) which is followed by cells addresses with the data that should be calculated. Formulas must be entered by the user from the keyboard.

Functions are built-in programs with unique names that consist of concrete values of function arguments located in parentheses after their names. Functions arguments are specified in special dialog boxes.

FORMATS OF DATA REPRESENTATION IN CELLS

Numerical data can be represented using various formats.

The General format is used to display both text and numeric data of any type.

The Number format with a fixed number of decimal digits is used for representation of numbers in cells with a specified accuracy. The number of decimal digits and accuracy are assigned by the user. This format allows to set a digit group separator, which is convenient for representation of large numbers, where every three digits should be separated.

The Percentage format represents data in percent form with the percent sign (%).

The Currency format provides representation of numbers with every three digits separated, and adds the currency symbol, e.g.: 2000 $.

The Scientific format displays a number in exponential notation and is used for representation of very big or very small numbers, e.g. number 2 050 000 000 = 2,05·10^9 = (2,05E+9). The scientific format is shown in the parentheses, thus E (stands for Exponent) multiplies the preceding number 2,05 (the mantissa) by 10 to the 9th power. This format also provides representation of numbers with user-defined accuracy, specifying the number of decimal digits.
CREATING, SAVING AND OPENING OF A WORKBOOK

CREATING AND ADJUSTMENT OF A WORKBOOK

To create a new workbook, you need to launch Excel using the Start menu → All Programs → Microsoft Office → Microsoft Office Excel. When Excel starts, it creates a new blank workbook, named Book 1. To create a new workbook in already opened program window, follow these steps: click the Office button, then select New → Blank workbook and click the Create button.

The Excel workbook is a file with the file extension .xlsx. A workbook may contain up to 255 worksheets arranged in a random order (by default, Excel provides 3 worksheets in a workbook). To specify standard settings for a blank workbook, click Options in the Office button menu.

The Excel Options window (fig. 2) allows to set the following parameters:
– number of worksheets in a new workbook;
– default font and font size;
– default file saving location;
– number of recent files stored in system memory, etc.

![Excel Options window](image)

Fig. 2. Excel Options window

Cells of a worksheet also have a specified format, which can be set by the command Format → Format Cells on the Home tab or by the context menu command Format Cells. The Format Cells dialog box has several tabs (fig. 3.):
– Number tab allows to set the categories of values in cells and formats codes;
– Alignment tab determines data alignment in cells, text orientation (horizontal, vertical, word wrap within cells);
– **Font** tab allows to change the font, style, size, color, underlining and different effects of the text in selected cells;
– **Border** tab allows to create frames or lines around a cell or blocks of cells;
– **Fill** tab allows to set cells filling (color and pattern);
– **Protection** tab allows to hide formulas and lock cells (prohibition of editing).

![Format Cells dialog box](image)

**Fig. 3. Format Cells dialog box**

**WORKBOOK SAVING**

The first saving of a workbook is carried out by the **Save As** command, located in the **Office** button menu. In the **Save As** dialog box (fig. 4) chose the format of the document that you want to save, enter its name in the **File name** field using the keyboard, specify the saving location (drive and folder) in the **Folder** field and click **Save**.

![Save As dialog box](image)

**Fig. 4. Save As dialog box**
The Excel workbooks are saved with the default file extension `.xlsx`. Re-saving of the file (without making any changes) is performed by clicking the Save button on the Quick Access toolbar or in the Office button menu (fig. 5).

**Fig. 5. Office button menu**

**WORKBOOK OPENING**

If a workbook has been created and saved previously, it can be found and opened for further work. Excel saves the sequence of documents used recently, as a list, which is located in the right area of the Office button menu (fig. 5). A previously saved workbook can be opened for further changes by selecting it from the list of recently saved documents or using the Open command. In the Open dialog box specify the drive and location of the file in the Folder field and select the file extension in the File Type box. Select the file that you need with the mouse and click Open.

**DATA ENTERING AND EDITING**

To enter any data into a cell follow these steps:
1. Select the cell with the mouse or from the keyboard.
2. Type the data from the keyboard.
3. Data entering is completed after pressing the Enter key. Another way to complete the data input is the use of the arrows keys of the keyboard to move the cursor. It is more convenient, as the data input is completed and the cursor moves on to the next cell in the arrow direction.

To edit any type of data you may use the formula bar: select the editable cell, click on the formula bar to activate it and edit the data. To the left of the formula
bar there is the **Cancel** button \(\times\), which allows to undo the last changes, in case you didn’t press **Enter** and didn’t click the **Enter** button \(\checkmark\), that confirm the changes that have been made.

**WORKBOOK EDITING**

**Editing** means making any changes of the original version of the workbook (misprint correction, data alteration, calculating totals, addition of rows, columns and worksheets, cleaning and removal of cells).

To **move data** from one place to another within a worksheet, you can use the **Cut** and **Paste** icons that are located on the **Home** tab, in the **Clipboard** group. When you cut a block of cells they appear in a dotted-line frame. Once the new location for the data block has been selected, use the **Paste** command. The same commands can be found in the context menu.

To **copy data** use the commands **Copy** and **Paste** on the **Home** tab, in the **Clipboard** group. When you copy a block of cells they appear in a dotted-line frame. Select the cell or group of cells where you want to copy the data, and click the **Paste** command or press **Enter**. You can use the same commands in the context menu. The easiest way to copy data is to select the cell that you want to copy, place the mouse pointer in the selected lower-right corner until the **AutoFill Marker** (+) appears, hold down the **left** mouse button and drag the rectangle to the copying area, and then release the mouse button. In this case, if you copy a formula, it will be automatically readdressed.

To **rename a worksheet**, click on the worksheet name (e.g. **Sheet 3**) with the right mouse button, activating the context menu (fig. 6), select **Rename** command, enter a new name of the worksheet and press **Enter**.

To **add new rows, columns and worksheets** use the **Home** tab, the **Cells** group and the commands **Insert/Insert Sheet Rows** or **Insert Sheet Columns**. In this case the existing data are shifted down or to the right.

First, place the cursor in the row above which you want to insert a new one, and then select the command **Insert/Insert Sheet Rows**.

After that, place the cursor in the column before which you want to insert a new one and select the command **Insert/Insert Sheet Columns**.

To insert a new worksheet, click the worksheet that should follow a new one to activate it and select the command **Insert/Insert Sheet**.
**Filling the data series** means filling the ranges of cells with repeated values or sequences of values, called series. To enter a data series you can use a special mouse technique, called **AutoFill**. To perform an **AutoFill** hold down the right mouse button and drag the **AutoFill Marker** (little black plus sign) in the lower right corner of the cursor over the cells. When the context menu appears, select the command **Fill Series, Copy Cells** or another appropriate command.

**OPTIMIZATION OF WORK USING TEMPLATES**

To create new workbooks with certain parameters you can use templates. **Template** is a workbook created and used as the initial version of all new workbooks. You can create your own templates of workbooks and worksheets. A template can include formatting parameters, standard text, such as page titles, rows and columns headers, formulas, macros, pictures, etc.

The standard template of the workbook can be changed (default template is Book.xltx). The workbooks created by clicking **New** command are based on the default workbook template.

You can create additional custom templates designed for specific tasks and drawing up medical documents. To save a template-file, open the **Save As** window and select the template in the field **Save as** type.

**WORKING WITH BLOCKS (RANGES) OF CELLS**

In the Excel spreadsheets there is a notion of the blocks (ranges) of cells, which also have their own unique addresses. A **block of cells** is a group of successive adjacent cells. A block of cells can consist of a row or its part, column or its part, or a rectangle composed of several rows and columns or their parts. A block address consists of the references of its first (upper left) and last (bottom right) cells, separated by the colon “:”, e.g.:

- the address of the cell situated at the intersection of the column G and the row 3 is recorded as **G3**;
- the address of the block formed as a part of the row 1 from the column A to the column E is recorded as **A1:E1**;
- the address of the block formed by a rectangle (fig. 7) is recorded as **A1:C5**.

*Fig. 7. Block of cells A1:C5*

Each command in the Excel spreadsheet requires indication of the referred cell or block (range) of cells.

Block addresses can be specified in two ways: entering the initial and final cells addresses of the range directly from the keyboard (necessarily in English layout), or selecting the required part of the spreadsheet with the mouse or keyboard. The most convenient way to specify a block is selecting of cells with
the mouse. To select the entire row or column, click its header with the left mouse button.

The content of cells or blocks can be copied, inserted, deleted, or formatted. First, you should select the required cell or block of cells, and then choose the command from the menu. To select a block, click the first cell in the range, hold down the left mouse button, and drag the mouse pointer over the remaining cells you want to select.

To format a block of cells: select a cells range, open the context menu, click Format Cells. The Alignment tab allows to set horizontal or vertical alignment of the cell content, cells width AutoFit (Shrink to fit). The Font tab allows to set the font type, size and style. The Border tab allows to set the type, format and position of the cell borders. The Fill tab is used to set the filling color and pattern style.

To remove a block of cells: select a cells range, on the Home tab, in the Cells group, click Delete and specify the objects you want to delete (cells, rows, columns).

To insert a block of cells (rows, columns): select a cells range, click Paste, specify the shift direction (right or down), click Insert Sheet Rows or Insert Sheet Columns.

To copy a block of cells: select a cells range, on the Home tab, in the Clipboard group (or in the context menu), click Copy, set the cursor in the upper left cell of the block where you want to copy the selected range, and on the Home tab, in the Clipboard group (or the context menu), click Paste.

To clear a block of cells: select a cells range, on the Home tab, in the Editing group, click Clear, specify the object to be cleared: all, formats, content, comments.

To fill of a block of cells with values: enter the values at the beginning or at the end of the block for replication, select a block of cells (up, down, left, right from the initial cell) for filling, then on the Home tab, in the Editing group, click Fill and select the filling direction depending on the configuration of the block (down, up, right, left).

**CREATING OF FORMULAS IN A SPREADSHEET**

A formula is an expressions used to calculate a value. Here is an example of a formula which multiplies 2 by 3 and adds 5 to the result: =5+2*3. A formula may also include such elements as functions, references, constants.

Formula’s elements (fig. 8):

1. Functions. PI() function expresses the pi value: 3.142...

2. References (or names). Reference A2 expresses the value of cell A2.

3. Constants. Numbers or text values entered directly into a formula, e.g.: 2.
Operators. The operator ^ involutes a number, while the asterisk (*) performs multiplication.

Entering of all formulas begins with = (the equality sign). Operation symbols include: + (addition), - (subtraction), / (division), * (multiplication), ^ (involution); the relational operators include: >, > = (greater than or equal to), <, <= (less than or equal to), =, <> (equal to, not equal). Cells display the result of the formula calculation. To view the formulas themselves, on the Formulas tab, click Formula Auditing/Show Formulas or use the Formula bar.

The Formula bar displays the data entered into the cell and allows to edit the contents of the current cell (text, numerical values, formulas). It shows not the result of the calculation, but the formula or function of the current cell.

ABSOLUTE AND RELATIVE CELLS’ ADDRESSES

References are required to specify addresses of cells with data. A reference can be relative (A5), which means that it refers to cells in regard to the formula position. Therefore, when you copy, delete or paste cells that contain formulas, in some cases, the relative addresses in formulas are automatically changed. To cancel the automatic readdressing, use an absolute reference.

An absolute reference is a cell address that contains the original data and doesn’t change while copying or moving of the formula. To make a reference absolute enter the $ symbol before it, e.g.: A$4, $A$4. Here A$4 is a reference absolute to the row name (after copying of the reference the column name changes, while the row number remains unchangeable), and $A4 is a reference absolute to the column name (after copying of the reference the column name is saved, but the row number changes), $A$4 is a reference absolute both to the column name, and the row name (after copying of the reference both column and row names remains unchangeable). To turn a relative reference (A4) into an absolute one ($A$4) set the cursor on the reference and press F4.

There is another way to make a reference absolute either to the column name ($B3), or to the row number (B$3): in the formula bar enter the symbol “$” before the column name or before the row number.

METHODS OF AUTOMATIC CHANGE OF THE ADDRESSES IN FORMULAS WHILE COPYING

To simplify input of the single-type data and formulas from one cell (block of cells) to another, the Copy function can be used. After copying the data from one cell (block of cells) to another specified cell (block of cells), the initial cell preserves its data. At the same time, relative references are automatically adjusted, e.g.: cell D3 after being copied down changes the address to D4, D5 and so on (fig. 9). To disable automatic address adjustment, absolute cell references are used. Thus, the address $D$8 doesn’t change after being copied down (fig. 9).
After **moving** data from one cell (block of cells) into another specified cell (block of cells), the initial cell will be cleared. When you move a formula, its operand’s address automatically changes. As a result, after moving the relative location of cells that contain the moved formula and the original data is preserved as in the original formula.

**FUNCTIONS IN A SPREADSHEET**

Functions are predefined formulas that perform calculation of given values, called arguments, in the given order. Functions allow to simplify formulas in the worksheet’s cells. E.g.: cell B10 contains the function of summation of a cells’ range =SUM(B5:B9) (fig. 10).

Functions structure (fig. 11):
1. The equality sign (=), followed by the function name, opening parenthesis, list of arguments separated by commas and closing parenthesis.
2. The function name. In our example, the ROUND function rounds off the value in cell A10 to two digits.
3. Arguments. There are different types of arguments: numbers, text, logical values (TRUE or FALSE), arrays, cell references, constants.

A spreadsheet has a large number of built-in functions for different types of calculations: mathematical, statistical, logical, financial, date function, time function, etc. They are entered using **Insert Function**
dialog box (fig. 12), which is activated by the **Insert Function** command, on the **Formulas** tab, in the **Function Library** group, or by the button at the beginning of the formula bar. This dialog box shows the composition of each category of functions. First, select the **Function category**, then select **Function name** from the list, a brief function syntax is available at the bottom of the dialog box.

The arguments (addresses of cells or blocks of cells) can be entered both from the keyboard, or with the mouse (fig. 13).

![Function Arguments](image)

*Fig. 13. Function arguments* entering window

**CHARTS**

**PLOTTING CHARTS**

Charts are visual representation of spreadsheet numeric data. They are a powerful and popular tool, which is widely used for analysis and comparison of data, as well as its visualising.

Charts elements correspond to numeric values of a spreadsheet, and are represented by different geometrical figures (bars, lines, columns, sectors, points, etc.). There are 11 types of Excel built-in charts, each one has many subtypes. The choice of the chart is determined by the task it should solve.

Numerical data of a spreadsheet and its graphical representation have a rigid connection. If the original numeric data is changed, the size or location of the elements of the chart will be changed automatically. And vice versa, if an element of the chart is changed (increase or decrease of the column height, change of the point location), the corresponding numeric values of the spreadsheet will be changed automatically.

There are two types of charts depending on the location and peculiarities of design and editing:

- **embedded charts** are saved on the worksheet along with the data, which is more convenient for printing and graphic representation;
– *diagrammatic sheets* are full-screen charts on a new worksheet, which are widely used for design of slides, illustrations, etc.

To create a chart, select the block of cells that you want to summarize visually and then, on the **Insert** tab, in the **Charts** group, click the type of chart you want to create (fig. 14).

![Insert tab with Charts group](image)

**Fig. 14. Creating a chart**

A block of cells may include numeric data and additional information, used as the names of the original data, or indication of X axis markers.

A block of cells may contain non-adjacent cells of the same worksheet (fig. 15). In this case, the selected blocks must have the same configuration and the non-adjacent cells must form a rectangle.

![Non-adjacent blocks](image)

**Fig. 15. Non-adjacent blocks**

If the block of cells contains more than one column and more than one row, Excel interprets rows or columns as separate *series*, that contain *data elements*. If the range includes non-adjacent blocks of cells, the cells of subsequent blocks are considered as the continuation of the data elements of the series of the first selected block.

Before you create a chart, make sure that the data on the worksheet are arranged according to the chart type that you are going to use.

Creating histograms, bar charts, graphs, charts with zones, radar chart, pie chart, you can use one or several data columns (rows).
Surface charts must contain two data columns (rows), apart from the category names column (row).

Pie chart must not contain more than one data column (row), apart from the category names column (row).

To facilitate charts plotting, the data series should form adjacent cells of a single block. Also, Excel allows building charts based on the data distributed across the worksheets of the whole workbook or even several workbooks. In this case, adding of new data series or data elements is performed in the chart editing mode.

To plot a chart, follow the steps.
1. Select the fragment of the spreadsheet you want to visualize as a chart.
2. On the Insert tab, in the Charts group, click the chart type you need and select its sub-type in the gallery (see fig. 14). If there is no suitable chart type and sub-type in the Chart group, click button of the group and select the desired chart in the Insert Chart window.

The chart of the desired sub-type will appear on the worksheet (fig. 16).

![Fig. 16. Created chart](image)

Further editing of the chart appearance depends on the purpose it was created for.

Let’s consider the main issues of chart settings and editing.

All commands are applied to the whole chart or the chart’s elements that were selected.

To select a chart you should click anywhere in the chart area. When the chart is selected it appears in a frame. To select an element of the chart, click it. When the element is selected it appears in a frame with element markers (fig. 17). Linear elements (axes, trend lines, etc.) have no frames. The number of markers varies for different elements of charts. Only one element of a chart can be selected.
at the same time. To select particular elements you can also use the **Chart Elements** dropdown list, in the **Current selection** group, on the contextual tab **Chart Tools/Layout**.

![Chart](image)

**Fig. 17.** Selected chart elements

After you’ve created a chart, you can change its type and appearance. For this purpose on the **Chart Tools/Design** tab, in the **Type** group, click **Change Chart Type**. In the **Change chart type** window select the desired type and style of the chart.

**DATA SOURCE CHANGE**

After you’ve create a chart, you can change the range of its data. For this purpose follow the steps.

- on the **Chart Tools/Design** tab, in the **Data** group, click **Select Data**;
- in the **Select Data Source** window, clean the field **Chart data range**, select a new data range on the worksheet (fig. 18).

![Data Source Change](image)

**Fig. 18.** Data source change
In case the chart is located on the same worksheet with the data, the data source range can be changed by dragging markers of the data range, which become visible on a worksheet after clicking on the chart (fig. 19). There are three main types of ranges: a green frame indicates the titles of the chart rows (cells A3:A6 in fig. 19), a lilac frame indicates the category titles (cells B2:E2 in fig. 19), a blue frame indicates data series values (cells B2:E6 in fig. 19).

Fig. 19. Change of the data source range by dragging the markers

To change the data series, drag the green frame to the required cells; to add or remove the data series drag the green selection handle.

To change the category, drag the lilac frame to the required cells; to add or remove the categories, drag the lilac selection handle.

To change both the categories and data series, drag the blue frame to the required cells (green and lilac frames will move automatically); to add or remove both the categories and data series, drag the blue selection handle.

The Select Data Source window can be used to change the data series, axes titles, legend. For this purpose, on the Chart Tools/Design tab, in the Data group, click Select Data. To add data series click the Add button (see fig. 18). In the Edit series window, clean the Series Name field, select the cell that contains the name of the data series, clean the Value field, and then select the cells that contain the values of the data series. To delete the data series, select the name of the series in the Select Data Source (see fig. 18) window and press Delete.

**Adding and Removal of Chart Elements**

You may change the appearance of the chart using the layout, which determines the presence and location of the chart elements.

On the Chart tools/Design tab, in the Chart Layouts group, click More Options (fig. 20).

Select suitable variant in the opened window.

Regardless of the chart layout, you can add and remove its elements. For this purpose, you can use the elements of the Chart tools/Layout tab, commands of the Titles and Axes groups (fig. 21).
Fig. 20. Selecting Chart Layout

For example, you can add a chart title. For this purpose, on the Chart tools/Layout tab, in the Labels group, click the Chart title button. Choose the position the chart title from the list (fig. 22). Type the name of the chart from the keyboard in the Chart title field.

Fig. 22. Selecting location of the chart title

To delete the title, in the Chart Title button menu, select None.

By analogy, you can add and remove other chart elements.

Besides, to remove any chart element, you can select it and press Delete.

Fig. 21. Adding and removing chart elements
Location of the chart elements is determined by the selected layout. However, you can change the location of some elements, such as the plotting field, legend, chart title, axes titles. To do this, select the element and drag its frame within the chart area.

**CHANGING OF CHART LOCATION**

A default chart created on the same worksheet with its data is located somewhere in the middle of the visible part of the worksheet. To change its location, select the chart and drag it to a new location in any part of the worksheet.

A chart plotted on a worksheet with the data can be moved to a separate worksheet. For this purpose, on the Chart tools/Design tab, in the Location group, click Move chart button. In the Chart location window (fig. 23), select the check box *On a separate worksheet*. If necessary, enter the name of the created worksheet with a chart.

![Chart location window](image.png)

*Fig. 23. Changing of chart location*

When you move a chart on a separate worksheet, a new worksheet is created automatically. Work with such a worksheet is equal to the work with a chart plotted on a worksheet with the data.
PRACTICAL TASKS

Practical task 1. BASIC FUNCTIONALITIES OF THE EXCEL SPREADSHEETS

Main issues:
1. Data input and editing.
2. Input, use and editing of formulas.
3. Function Wizard.

Exercise 1. ENTERING OF VARIOUS TYPES OF DATA INTO A SPREADSHEET

Enter the data about purchase of medicines according to the table.

<table>
<thead>
<tr>
<th>Medicine name</th>
<th>Price for a package</th>
<th>Quantity</th>
<th>Sum</th>
<th>Percent</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bronhypret</td>
<td>9.46 р.</td>
<td>7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gastal</td>
<td>1.36 р.</td>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Osteotab</td>
<td>11.52 р.</td>
<td>12</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Travopassit</td>
<td>3.60 р.</td>
<td>15</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To obtain the above mentioned table, follow the steps.
1. Run Excel.
2. Save the created workbook under the name Calculations in the working folder:
   – click Save as command → Excel Workbook;
   – in the Save As window, in the Folder field, specify the name of the folder where the document will be saved;
   – in the File Name field, type Calculations;
   – click the Save button.
3. Enter the name of the table in cell B1:
   – click cell B1;
   – type “Buying medicines”.
4. Design the header of the table as shown in fig. 24. For this purpose, do the following:
   – click cell A2;
   – type the title of the first column of the table “Medicine name”;
   – complete the entry by pressing the Enter key;
   – click cell B2;
– type the title of the second column “Price for a package”, complete the entry by pressing the Enter key;
– click cell C2;
– type the title of the third column “Quantity”, press Enter;
– in cell D2, enter the title of the fourth column “Sum”, complete the result pressing the Enter key.

5. Increase the width of the column A. For this purpose, select the column A by clicking on its header and click twice the right border of the column header.

6. Type the data from the task 1 into three columns of the table in accordance with fig. 25. For this purpose, fill in the block of cells A3:C6 in the same way.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>Medicine name</td>
<td>Price for a package</td>
<td>Quantity</td>
<td>Sum</td>
</tr>
<tr>
<td>Bronhypret</td>
<td>9,46</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>Gastal</td>
<td>1,36</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>Osteotab</td>
<td>11,52</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>Travopassit</td>
<td>3,60</td>
<td>5</td>
<td></td>
</tr>
</tbody>
</table>

Fig. 25

**Exercise 2. CREATING FORMULAS AND USING THEM FOR CALCULATION**

Make calculations of the expenses for each purchase separately and calculate the total sum according to the table. Use formulas.

1. As the Column D is reserved for calculation of sums, enter the formulas for sum calculation in cells D3:D6 (fig. 26). Follow the steps:
   – set the cursor in the cell where you want to put the result of the calculation, in our example it is cell D3;
   – type = (equality sign);
   – click cell B3, which contains the first of the multiplied numbers; the address of that cell will be automatically recorded into the formula;
   – type the symbol * (multiplication sign) from the numeric keypad;
   – click cell C3, which contains the second of the multiplied numbers; the address of that cell will also appear in the formula automatically;
   – press Enter to obtain the result.

2. Use the same way to enter the calculation formula in cell D4 (fig. 27).
3. As the column D contains single-type formulas, it is more convenient to insert a single formula and then copy it down to any number of cells using the **AutoFill Marker**. To copy the formula from cell D4 into cells D5 and D6 select cell D4, where you have already entered the formula, set the cursor to the lower right corner of cell D4 until the **AutoFill Marker** appears in the form of the sign+ (plus sign), click and hold the left mouse button and drag the selected area down to cell D6, then release the mouse button. When copying a formula down, the relative links are automatically redirected (fig. 28). The result of your actions is shown in fig. 29.

![Fig. 28](image)

![Fig. 29](image)

### Exercise 3. **BUILT-IN FUNCTIONS**

Calculate the **Total** sum of the table using the built-in function **SUM**. For this purpose, follow the steps:

1. Type the text “Total” in cell A7.
2. Calculate sums of columns B, C and D of the table using the **AutoSum** icon on the **Home** tab, in the **Editing** group or on the **Formulas** tab, in the **Function Library**. To do this, set the cursor in cell B7 and click the **AutoSum** icon on the **Home** tab, in the **Editing** group or on the **Formulas** tab, in the **Function Library** group. As a result, the function =SUM (range of cells) will appear in the active cell A7, and a blinking frame will mark out the range of cells you’ve selected for summation (fig. 30). If the range of cells is incorrect, you can edit it selecting the required cells with the mouse.
3. Use the same way to summarize the data in columns C and D.

The result of your actions is shown in fig. 31.

![Fig. 30](image)

![Fig. 31](image)
Exercise 4. ABSOLUTE REFERENCES.
COPYING FORMULAS WITH REFERENCES

Calculate the percentage of the amount paid for each medicine to the total sum using an absolute reference.

The percentage ratio is calculated by the equation \( \frac{\text{Sum}}{\text{Total}} \), and is expressed as a decimal fraction. Another way to display quickly the result as a percentage ratio is to click the **Percentage format** icon \( \% \) on the **Home** tab, in the **Number** group. These formulas can be used for calculation of the percentage ratio of the sums paid for other purchases to the total sum, but if the formulas are similar, it is easier to copy them down using the **AutoFill marker**. It should be noted that to perform this operation the reference of cell D7 must not be changed (absolute reference), so fix it by pressing the F4 key.

To calculate the percentage ratio, follow the steps (fig. 3.2):

1. Enter the formula \( =D3/D7 \) in cell E3. To make the reference absolute click the D7 reference in the formula bar and press the F4 key, then fix the formula pressing Enter.
2. Copy down the formula from cell E3 to cells E4:E7 with the **AutoFill marker**.

![Fig. 32](image)

The result of your actions is shown in fig. 3.3.

![Fig. 33](image)
Exercise 5. Spreadsheet Editing

Edit the source data in the spreadsheet and make sure that the result will be automatically recalculated in all formulas. For this purpose do the following:

1. Add a new blank row between rows 4 and 5. Fill it with new data. Blank rows are always inserted above the cursor, so set the cursor in any cell in the row 5, click the right mouse button to open the context menu, select Insert... and click the Row check box in the Add cells field. Type “Bromhexine” in the empty cell A5, “2,42” in cell B5, “3” in cell C5.

2. Copy the formulas from cells D4:E4 in cells D5:E5. For this purpose, select the range of two cells D4:E4 and place the cursor on the lower right corner of the selected range of cells. When you see the AutoFill marker + (plus sign) click and hold down the left mouse button, drag the selection down to cell E5, then release the mouse button. Press Enter and make sure that cells B8, C8, D8 and column E have been automatically recalculated according to the formulas.

The result of your actions is shown in fig. 34.

<table>
<thead>
<tr>
<th>1</th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Medicine name</td>
<td>Price for a package</td>
<td>Quantity</td>
<td>Sum</td>
<td>Percent</td>
</tr>
<tr>
<td>3</td>
<td>Bronhypret</td>
<td>9,46</td>
<td>5</td>
<td>47,30</td>
<td>0,4811</td>
</tr>
<tr>
<td>4</td>
<td>Gastal</td>
<td>1,36</td>
<td>2</td>
<td>2,72</td>
<td>0,0277</td>
</tr>
<tr>
<td>5</td>
<td>Bromhexine</td>
<td>2,42</td>
<td>3</td>
<td>7,26</td>
<td>0,0738</td>
</tr>
<tr>
<td>6</td>
<td>Osteotab</td>
<td>11,52</td>
<td>2</td>
<td>23,04</td>
<td>0,2343</td>
</tr>
<tr>
<td>7</td>
<td>Travopassit</td>
<td>3,60</td>
<td>5</td>
<td>18,00</td>
<td>0,1831</td>
</tr>
<tr>
<td>8</td>
<td>Total</td>
<td>28,36</td>
<td>17,00</td>
<td>98,32</td>
<td>1</td>
</tr>
</tbody>
</table>

Fig. 34

3. Change the contents of cells A6 and B6, and watch how the spreadsheet is automatically recalculated according to the formulas:
   – enter the name of one more medicine “Mebicar” in cell A6 and new price “4,40” in cell B6;
   – press Enter and make sure that cells D6, E6, D8 and E8 have been automatically recalculated.

4. Cancel the last two actions (changing of the content of cells A6 and B6), restoring the previous variant of the spreadsheet:
   – click twice the Undo icon on the Quick Access Toolbar in the upper left corner of the screen;
   – make sure that the data in row 6 returned to the variant represented in fig. 34.

Exercise 6. Spreadsheet Formatting

1. Format the resulting spreadsheet: specify the data format in columns B and D as currency, and percentage format for column E. Follow the steps:
- select the range of cells B3:B8;
- press and hold the Ctrl key (as the ranges of cells are non-adjacent), then select the second range D3:D8;
- on the Home tab, in the Cells group, click Format and select Format cells in the opened menu (fig. 35);
- in the Format cells dialog box (fig. 36), in the Number tab, select the Currency format;
- set the number of decimal places as 0, choose the symbol ₽;
- click OK to confirm the settings;
- select the next range of cells E3:E8;
- on the Home tab, in the Cells group, click Format, then click Format cells;
- in the Format cells window, on the Number tab, select the Percentage format (fig. 37);
- set the number of decimal places as 2;
- click OK to confirm the settings.

The result of your actions is shown in fig. 38.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Medicine name</td>
<td>Price for a package</td>
<td>Quantity</td>
<td>Sum</td>
</tr>
<tr>
<td>2</td>
<td>Buying medicines</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Bronhpret</td>
<td>9,46p.</td>
<td>5</td>
<td>47,30p.</td>
</tr>
<tr>
<td>4</td>
<td>Gastal</td>
<td>1,36p.</td>
<td>2</td>
<td>2,72p.</td>
</tr>
<tr>
<td>5</td>
<td>Bromhexine</td>
<td>2,42p.</td>
<td>3</td>
<td>7,26p.</td>
</tr>
<tr>
<td>6</td>
<td>Ostotab</td>
<td>11,52p.</td>
<td>2</td>
<td>23,04p.</td>
</tr>
<tr>
<td>7</td>
<td>Travopassit</td>
<td>3,60p.</td>
<td>5</td>
<td>18,00p.</td>
</tr>
<tr>
<td>8</td>
<td>Total</td>
<td>28,36</td>
<td>17,00</td>
<td>98,32</td>
</tr>
</tbody>
</table>
2. Add filling of cells of the table heading. Follow the steps:
– select the range of cells A2:E2;
– on the Home tab, in the Cells group, click Format, then click Format cells;
– when the Format cells window appears, on the Fill tab, select any light color in the Background Color palette.
3. Add the outline frame of the table and design it as a double line:
– select the table (the range of cells A2:E8);
– on the Home tab, in the Cells group, click Format, then click Format cells;
– in the Format cells window, on the Border tab, in the Line style list, select the double line, then in the Presets group, select the Outline borders.
4. Add the inside borders of the table and design them as a dotted line. For this purpose, on the abovementioned Border tab, in the Line style list, select the dotted line, and in the Presets group, select the Inside borders.

The result of your actions is shown in fig. 39.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Buying medicines</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Medicine name</td>
<td>Price for a package</td>
<td>Quantity</td>
<td>Sum</td>
</tr>
<tr>
<td>3</td>
<td>Bronhynpret</td>
<td>9,46p.</td>
<td>5</td>
<td>47,30p.</td>
</tr>
<tr>
<td>4</td>
<td>Gastal</td>
<td>1,36p.</td>
<td>2</td>
<td>2,72p.</td>
</tr>
<tr>
<td>5</td>
<td>Bromhexine</td>
<td>2,42p.</td>
<td>3</td>
<td>7,26p.</td>
</tr>
<tr>
<td>6</td>
<td>Osteotab</td>
<td>11,52p.</td>
<td>2</td>
<td>23,04p.</td>
</tr>
<tr>
<td>7</td>
<td>Travopasit</td>
<td>3,60p.</td>
<td>5</td>
<td>18,00p.</td>
</tr>
<tr>
<td>8</td>
<td>Total</td>
<td>28,36</td>
<td>17,00</td>
<td>98,32</td>
</tr>
</tbody>
</table>

**Fig. 39**

Practical task 2. GRAPHICAL REPRESENTATION OF DATA. CHARTS

Main issues:
1. Building charts using the Chart Wizard.
2. Charts formatting and editing.

**Exercise 1. EMBEDDED CHARTS**

Build a chart showing the ratio of sums paid for medicines.
To create a chart based on the columns “Name of medicine” and “Sum”, follow these steps:
– select cells A2:A7 which contain the source data required to build the chart;
– press and hold the Ctrl key (as the ranges of cells are non-adjacent), select the second range D2:D7;
– on the **Insert** tab of the Ribbon, in the **Charts** group, select the **Pie chart** type → **3D Pie** → **Exploded Pie in 3D** (fig. 40).

![Chart 2](#)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Buying medicines</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Medicine name</td>
<td>Price for a package</td>
<td>Quantity</td>
</tr>
<tr>
<td>3</td>
<td>Bronhypret</td>
<td>9.46p.</td>
<td>5</td>
</tr>
<tr>
<td>4</td>
<td>Gastal</td>
<td>1.36p.</td>
<td>2</td>
</tr>
<tr>
<td>5</td>
<td>Bromhexine</td>
<td>2.42p.</td>
<td>3</td>
</tr>
<tr>
<td>7</td>
<td>Travopassit</td>
<td>3.60p.</td>
<td>5</td>
</tr>
<tr>
<td>8</td>
<td>Total</td>
<td>28.36</td>
<td>17.00</td>
</tr>
</tbody>
</table>

**Fig. 40**

The result of your actions is shown in fig. 41.

![Buying medicines](#)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
<th>L</th>
<th>M</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Buying medicines</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Medicine name</td>
<td>Price for a package</td>
<td>Quantity</td>
<td>Sum</td>
<td>Percent</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Bronhypret</td>
<td>9.46p.</td>
<td>5</td>
<td>47.30p.</td>
<td>48%</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Gastal</td>
<td>1.36p.</td>
<td>2</td>
<td>2.72p.</td>
<td>3%</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Bromhexine</td>
<td>2.42p.</td>
<td>3</td>
<td>7.26p.</td>
<td>7%</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Osteotab</td>
<td>11.52p.</td>
<td>2</td>
<td>23.04p.</td>
<td>23%</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Travopassit</td>
<td>3.60p.</td>
<td>5</td>
<td>18.00p.</td>
<td>18%</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Total</td>
<td>28.36</td>
<td>17.00</td>
<td>98.32</td>
<td>100%</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Fig. 41**

To correct the chart title, click the title bar of the chart, delete the word “Sum” and type “Buying medicines”.

To add data labels do the following:

– on the **Chart tools/Layout** tab, in the **Labels** group, click **Data Labels** → **Outside End** (fig. 42);

– select the data labels in the chart, clicking on any of them with the mouse, then on the **Chart tools/Layout** tab, in the **Current Selection** group, click **Format Selection**. In the opened window, in the **Labels Options** section, in the **Label Contains** field, click the Percentage check box;

– select **New Line** as the **Separator** between the labels, by clicking the dropdown list button and selecting this option from the list.

Your actions will result in the chart shown in fig. 43.
Exercise 2. CHARTS FORMATTING

Format the chart in the following way: increase the plot area, change the color of a segment, fill the chart area and change the legend format. Follow these steps:

1. Edit the chart:
   – click the chart to select it;
– set the cursor on the corner frame marker of the chart until the double-
arrow pointer appears, and drag it with the mouse to change the chart’s size;
– click the plot area (fig. 44) to select it, set the cursor at the corner pointer
of the area’s border, lift the frame of the chart changing its height.

2. Change the color of a segment of the chart:
– click a segment of the chart (all segments will be selected), click it once more, and it will become
the only selected segment;
– click the selected segment with the right mouse button to display the context menu and select
Format data point (fig. 45);
– when the Format data point window appears (fig. 46), in the Fill section click the Solid fill check
box, choose another color in the palette for the selected segment, click Close.

3. To fill the chart area, do the following:
– click the chart area with the right mouse button to
select it;
– in the context menu select Format chart area;
– in the Format chart area window, in the Fill
section click the Gradient fill check box (fig. 47);
– in the Gradient Stops section set three points;
– for each stop sequentially set the color and, if
necessary, position and transparency;
– in the Type field select Radial;
– set the Direction field as it is shown in fig. 48.
4. Format the chart legend as follows:
- click the legend with the right mouse button to select it;
- in the context menu click Format Legend;
- when the Format legend window appears, in the Legend Options section, select Bottom;
- in the Fill section, select No fill;
- in the Border Color section, select No lines.
The result of your actions is shown in fig. 49.

![Pie Chart](image)

**Fig. 49**

**Exercise 3. CHARTS EDITING**

Change the data area, to obtain a chart arranged according to the columns Name of medicine and the Quantity. Observe the changes in the chart. Change the values in the row 3 in the columns Name of medicine and Quantity and make sure that the chart has changed automatically. Rename the chart as “Quantity of medicines bought”. Change the chart format and compare the result with the previous version.

1. To change the original data area, do the following:
   - set the cursor on the chart area and click the right mouse button to activate the context menu;
   - in the context menu choose Select data (or use the Chart Tools/Design tab → Select data);
   - in Select data source window, the Chart Data Range field contains the address of the cell ranges A2:A7 and D2:D7, which were used to plot the chart (in the spreadsheet they will appear in a blinking frame);
   - select the former range of the names of medicines A2:A7, then hold down the Ctrl key (as the cell ranges are non-adjacent) and select the second range C2:C7 (fig. 50);
– click **OK**.
– analyze the changes in the chart.

![Select Data Source](image)

Fig. 50

2. To change the values in cells **A3** and **C3**, do the following:
   – set the cursor in cell **A3** and type a new value “Tolperisone”;
   – set the cursor in cell **C3** and type a new value “4”;
   – take notice of the changes appeared in the chart.
3. To change the chart header, follow the steps:
   – click the chart title to select it, click it one more time to activate the title editing mode;
   – change the text for “Quantity of medicines bought”.
4. To change the chart format, do the following:
   – set the cursor in the chart area and click the right mouse button to activate the context menu;
   – in the opened context menu select **Change Chart Type**;
   – in the **Change Chart Type** menu select the chart type **Column → Clustered Column**, click **OK**.
5. To remove the legend, select it with a mouse click and press **Delete** key.
6. To make the *plot area* transparent, do the following:
   – set the cursor on the plot area and click the right mouse button to activate the context menu;
   – in the opened context menu select the **Format Plot Area** command;
   – in the **Format Plot Area** window, in the *Fill* section, click the *No fill* check box;
   – click **Close**.
7. To add axis titles in the chart, follow the steps:
– in the Chart Tools/Layout tab, in the Labels group, click Axis Titles (fig. 51);
– select the axis (horizontal or vertical), where you want to add a title;
– select the location of the axis title from the list;
– click the horizontal axis title to activate the editing mode, and type “Medicine name”;
– click the vertical axis title to activate the editing mode, and type “Quantity”.

Fig. 51

The result of your actions is shown in fig. 52.

Fig. 52

SELFCONTROL TASKS

Task 1. Look at the table illustrating a hospital performance data for the three years. Create a spreadsheet and use formulas to calculate the number of prospected patients (plan) and the number of currently treated patients (fact).

<table>
<thead>
<tr>
<th>Hospital performance</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Year</strong></td>
</tr>
<tr>
<td>Plan</td>
</tr>
<tr>
<td>Fact</td>
</tr>
<tr>
<td>Percentage</td>
</tr>
</tbody>
</table>

Then, calculate the percentage ratio (= fact/plan).
Build a three-dimensional histogram based on the obtained data, as it is illustrated in the figure.

![Hospital performance graph]

**Task 2.** Look at the table containing information about the number of influenza cases among pupils of an elementary school.

**Information about the influenza cases in the elementary school**

<table>
<thead>
<tr>
<th>Grades</th>
<th>Number of pupils</th>
<th>Number of sick persons</th>
<th>Percentage of sick pupils, %</th>
</tr>
</thead>
<tbody>
<tr>
<td>First</td>
<td>130</td>
<td>45</td>
<td></td>
</tr>
<tr>
<td>Second</td>
<td>125</td>
<td>36</td>
<td></td>
</tr>
<tr>
<td>Third</td>
<td>120</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>Fourth</td>
<td>128</td>
<td>35</td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Use formulas to calculate the total number of pupils, the number of cases and percentage of sick persons in % (*the number of cases divided by the number of pupils*). Plot a bar chart illustrating the percentage of cases by grades.

![Information about the influenza cases bar chart]
Systolic (BPsis) and diastolic (BPdis) blood pressure of 16 patients have been measured. Enter the data obtained in a spreadsheet, as shown in fig. 53. Plot a graph showing the systolic blood pressure value for each patient.

1. To plot a graph based on BPsis column, follow the steps:
   - select the cells containing the source data B3:B18;
   - in the Ribbon, on the Insert tab, in the Charts group, select the Line chart type → Line with markers (fig. 54);
   To insert the line chart title and axis titles:
   - on the Chart Tools/Layout tab, in the Labels group (see fig. 51), click Chart Title and select its location;
   - click Axis Titles and set the parameters of the horizontal and vertical axes;
   - click on the chart title to activate the editing mode, and type “Blood Pressure Graph”;
   - click on the horizontal axis title to activate the editing mode, and type “Patients”;
   - click on the vertical axis title to activate the editing mode, and type “BPsis, mm Hg.”;
2. Click the legend to select it, press Delete.

The result of your actions is shown in fig. 55.
Exercise 2. Line Graph Formatting

Update the graph: make the chart area transparent and change the reference point of the vertical scale.

1. Make the chart area transparent:
   - click the chart area with the right mouse button to select it.
   - in the context menu select Chart Area Format;
   - in the Chart Area Format window, in the Fill section, click the No Fill check box;
   - click Close.

2. Change the reference point of the vertical scale:
   - set the cursor on the vertical axis, click the right mouse button to activate the context menu;
   - select Format axis command in the context menu;
   - in the Format axis dialog box (fig. 56), in the Axis Options section, in the Minimum value field, click the Fixed check box and enter “60”; in the Maximum value field, click the Fixed check box and enter “200”; in the Major unit field, click the Fixed check box and enter “20”; click Close.

The result of your actions is shown in fig. 57.
Exercise 3. BUILDING SEVERAL GRAPHS ON THE SAME AXES TO ILLUSTRATE THE VALUES OF SEVERAL VARIABLES

Using the data of the previous task, plot graphs in the same axes. The graphs should illustrate the values of systolic and diastolic blood pressure of each patient. Make a title, add axes titles, add the legend.

To plot two graphs based on the BPsis and BPdis columns, do the following:
- select the range of cells with the source data B2:C18;
- on the Ribbon, on the Insert tab, in the Charts group, select the Line chart type → Line with markers.

2. To insert a chart title and axis titles:
- on the Chart tools/Layout tab, in the Labels group, click Chart Title and select its location;
- click Axes Titles and set the parameters for horizontal and vertical axes;
- click on the chart title to activate the editing mode, and type “Systolic and diastolic pressure graphs”;

- click on the horizontal axis title to activate the editing mode, and type “Patients”;
- click on the vertical axis title to activate the editing mode, and type “BP, mm Hg.”;

The resulted graph is shown in fig. 58.
Exercise 4. Plotting a graph illustrating the interdependence of values. Scatter chart

In accordance with the given data, illustrating the connection between the mass of the enzyme “m” produced in the fermentation process, and the time “t” that the reaction lasts, plot a graph showing mass-time dependence.

1. Move to a new worksheet. Enter these data in a spreadsheet, as shown in fig. 59.

2. To plot a graph:
   – select the range of cells A2:B9;
   – on the Ribbon, on the Insert tab, in the Charts group, select Scatter → Scatter with Smooth Lines and Markers (fig. 60).

3. To add a chart title and axis titles:
   – on the Chart Tools/Layout tab, in the Labels group, click Chart Title and select its location;
   – click Axes Titles and set parameters of horizontal and vertical axes;
   – click on the chart title to activate the editing mode and type “Enzyme mass and reaction time dependence”;
   – click on the horizontal axis title to activate the editing mode and type “Time, h”;
   – click on the vertical axis title to activate the editing mode and type “Mass, g”.

4. To add vertical gridlines:
   – on the Chart Tools/Layout tab, in the Axes group, click Gridlines and in the Primary Vertical Gridlines menu select the required variant.
5. To fill the plot area, follow the steps:
   – click the plot area with the right mouse button to activate the context menu, select **Format Plot Area**;
   – in the **Format Plot Area** window, in the **Fill** section, click the **Solid fill** check box, select the grey color in the palette, click **Close**.
   The result of your actions is shown in fig. 61.

![](image)

**Fig. 61**

**SELFCONTROL TASKS**

**Task 1.** Look at the table illustrating the heart rate (beats/min) in patients with ischemic heart disease (IHD) while admission to the hospital and discharge. Plot two charts showing the distribution of that index in patients **in the same axes**. Make a title, add the legend and axes titles.

<table>
<thead>
<tr>
<th></th>
<th>HR/min, admission</th>
<th>HR/min, discharge</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>115</td>
<td>88</td>
</tr>
<tr>
<td>2</td>
<td>101</td>
<td>85</td>
</tr>
<tr>
<td>3</td>
<td>97</td>
<td>76</td>
</tr>
<tr>
<td>4</td>
<td>109</td>
<td>74</td>
</tr>
<tr>
<td>5</td>
<td>101</td>
<td>86</td>
</tr>
<tr>
<td>6</td>
<td>149</td>
<td>90</td>
</tr>
<tr>
<td>7</td>
<td>137</td>
<td>88</td>
</tr>
<tr>
<td>8</td>
<td>109</td>
<td>83</td>
</tr>
</tbody>
</table>

**Task 2.** Plot a graph in accordance with the given data, illustrating the dependence between the reaction of the organism (the value of a certain biochemical parameter of blood) to the injected drug and the time. Determine the time after which the maximum response is achieved. Highlight this point in the chart by changing its format (color and size).

<table>
<thead>
<tr>
<th>Time, h</th>
<th>Reaction mmol/l</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0.37</td>
</tr>
<tr>
<td>1</td>
<td>0.55</td>
</tr>
<tr>
<td>2</td>
<td>0.46</td>
</tr>
<tr>
<td>3</td>
<td>0.30</td>
</tr>
<tr>
<td>4</td>
<td>0.17</td>
</tr>
<tr>
<td>5</td>
<td>0.09</td>
</tr>
<tr>
<td>6</td>
<td>0.05</td>
</tr>
</tbody>
</table>
Practical task 4. OPTIMIZATION OF WORK USING TEMPLATES

The main issues:
1. Template creation and saving.
2. Template editing.
3. Creating a document on the basis of a template.

Professional activities of the physician often require creating of single-type documents, such as reports, containing standard elements, texts, formulas, charts. To minimize the time needed for their preparation, one can create and save templates and use them as the base of new documents.

Exercise 1. CREATING A STANDARD REPORT TEMPLATE

Create and save a template of a standard report of a hygienist-epidemiologist in the Templates folder. Follow the steps:
1. Create a folder named Templates in your working folder.
2. Run Excel. The file Book 1 will appear on the screen.
3. Save the workbook under the name of Report Template in the Templates folder. To do this, follow these steps:
   - click the Office button, click Save as → Other Formats;
   - in the Save as window, in the Save as type field, click the drop-down list button and select Excel Template from the list of possible formats.
   - in the File name field, type “Report Template” (fig. 62);
   - the Folder field will automatically display the default folder named Templates, where the default user-created templates are saved; click the drop-down list button, select the Desktop, find your folder and click it;
   - click Open, then click Save.

4. Enter the data according to fig. 63.

In order to enter the table Header, follow the steps:
   - click cell B1;
   - type the text “Information on the revealed violations of the territory state” into this cell.

Add the columns and rows headers:
   - click cell A2;
   - enter the name of the first column “№”, complete the entry by pressing Enter;
   - click cell B2, enter the name of the second column “Objects”, complete the result by pressing Enter;
– in the same way, enter the headers of the rest columns in cells C2, D2, E2, F2, in accordance with fig. 63.

<table>
<thead>
<tr>
<th>№</th>
<th>Objects</th>
<th>Number of objects investigated</th>
<th>Number of violations revealed</th>
<th>Number of reports drawn up</th>
<th>Number of directions drawn up</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Elementary school and kindergartens</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Objects of sale and public catering, consumer service objects, including</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Objects of food sale and public catering</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Vendor kiosks, small-scale sale</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Objects of non-food sale</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Consumer service objects</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Courtyards</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Objects of Highway Maintenance UE, including</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bus stops</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Carriageway and pavements</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Other territories and objects</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>TOTAL (according to points 1-5)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Date</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Fill in the rows of the table (the range of cells A3:B14).**

5. To increase the width of column B, click column B with the mouse and then double-click in the right border of the column header.

**Exercise 2. FORMATTING OF A TABLE TEMPLATE**

Format the resulting table in accordance with fig. 63. Follow the steps:
1. Highlight the table header, changing the font format:
   – set the cursor in cell B1;
   – click the right mouse button to activate the context menu, click **Format Cells**.
   – in the **Format cells** dialog box (fig. 64) select the **Font** tab;
   – in the **Font style** list select “bold”, in the **Size** list select “14”.
2. Put the columns headers in bold:
   – select the range of cells A2:F2;
   – on the **Home** tab, in the **Font** group, click **Bold**.

![Fig. 63](image1)

![Fig. 64](image2)
3. Put the text in cells A3:A15 in bold in the same way.
4. To put the text in bold in several rows at the same time, hold down the Ctrl key (as the rows are non-adjacent), select the rows 3 and 4, 9, 10, 13, 14 and 15.
5. Combine the group of cells A1:D1 into one cell. To do it, follow the steps:
   – select the specified range of cells;
   – on the Home tab, in the Alignment group, click Merge;  
   – combine the second range of cells A14:B14 into one cell the same way.
3. Fill the range of the cells A2:F2:
   – select this range of cells;
   – on the Home tab, in the Font group, click Theme Colors, select any light color.

**Exercise 3. ENTERING FORMULAS**

Type the formulas for sums calculation into cells in accordance with fig. 65.

<table>
<thead>
<tr>
<th>A</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Number of objects investigated</td>
<td>Number of violations revealed</td>
<td>Number of reports drawn up</td>
<td>Number of directions drawn up</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>=SUM(C5:C8)</td>
<td>=SUM(D5:D8)</td>
<td>=SUM(E5:E8)</td>
<td>=SUM(F5:F8)</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>=SUM(C11:C12)</td>
<td>=SUM(D11:D12)</td>
<td>=SUM(E11:E12)</td>
<td>=SUM(F11:F12)</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>=SUM(C3:C4;C9:C10;C13)</td>
<td>=SUM(D3:D4;D9:D10;D13)</td>
<td>=SUM(E3:E4;E9:E10;E13)</td>
<td>=SUM(F3:F4;F9:F10;F13)</td>
</tr>
</tbody>
</table>

*Fig. 65*

Follow the steps:
1. Use the AutoSum button on the Home tab, in the Editing group, to calculate the sums of the columns C, D, E and F of the spreadsheet. To do this, enter the formula =SUM(C5:C8) in cell C4:
   – set the cursor in cell C4;
   – click the AutoSum button. As a result, the function =SUM (...) will appear in the active cell C4, and a blinking frame will highlight the range of cells proposed for summation;
   – the range of cells you need is C5:C8, so select it with the mouse;
   – as the cells contain no numeric data, the summation result will be 0.

2. Copy the formula from cell C4 into cells D4, E4 and F4, using the AutoFill Marker:
   – select cell C4;
– set the mouse pointer on the bottom right corner of cell C4 until the **AutoFill Marker** + (plus) appears, hold it with the left mouse button and drag the selection to the right to cell F4, and then release the mouse button. As the cells contain no numeric data, the result will be 0.

The formulas will be automatically readdressed, as shown in fig. 65.

3. Use the same way to enter the formula =SUM(C11:C12) in cell C10 and copy it to the right into cells D10, E10 and F10.
4. To calculate the total sum enter the formula =SUM(C3:C4;C9:C10;C13) in cell C14, as follows:
   – select cell C14;
   – on the **Home** tab, in the **Editing** group, click the **AutoSum** button \( \sum \). As a result, the function =SUM (...) will appear in the active cell C14, and a blinking frame will highlight the range of cells proposed for summation. Select the range of cells that you need with the mouse. Since the cells of the range for summation are non-adjacent, hold the **Ctrl** key while cells selection. First, select the range C3:C4, press and hold the **Ctrl** key, select the range C9:C10, then cell C13;
   – release the **Ctrl** key, press **Enter** to fix the formula.
5. Copy the formula from cell C14 to the right into cells D14, E14 and F14 using the **AutoFill Marker**.
6. Enter into a cell a formula that displays current updatable date. To do this:
   – select cell B15;
   – on the **Formulas** tab, in the **Function Library** group, click the **Insert Function** button (fig. 66);
   – in the **Insert Function** window select the category **Date and Time**;
   – scroll down the drop-down list, find and click the **Today** function (fig. 67), click **OK**.

The template is ready. The result of your actions is shown in fig. 68.

Save the template using the **Save** button on the **quick access toolbar** in the upper left corner of the window and close the file.
Create a new document based on the saved template. To do this, follow these steps:

1. Find the template you’ve created and saved. For this purpose:
   - start Excel. The file Book 1 will appear on the screen;
   - click the Office button in the upper left corner of the screen, then click New in the window menu;
   - in the New window, in the Available Templates field, select New from existing (fig. 69);
   - in the New from existing dialog box, find your folder and previously saved Report Template, select it, click Create.

The result of your actions will be a new workbook based on the selected template.

2. Save this workbook into your working folder under the name Violations Report.
For this purpose follow the steps:

– click the **Save** button on the *quick access toolbar* in the upper left corner of the window;

– in the *Save as* dialog box, in the **File name** field, type *Violations Report*;

– make sure that the **File type** field has been specified as *Excel Workbook* and the **Folder** field contains the name of your working folder;

– click **Save**.

3. Complete the spreadsheet with numeric values, except for the cells that contain formulas in rows 4, 10 and 14 (they currently display zeros), and observe how zeros turn into calculation results. For this purpose enter the following numeric values into the corresponding cells:

– C3:F3 — 13, 0, 0, 0;
– C5:F5 — 21, 0, 0, 0;
– C6:F6 — 0, 0, 0, 0;
– C7:F7 — 5, 0, 0, 0;
– C8:F8 — 9, 0, 0, 0;
– C9:F9 — 89, 5, 1, 0;
– C11:F11 — 69, 9, 0, 0;
– C12:F12 — 16, 3, 0, 0;
– C13:F13 — 11, 0, 0, 0.

Updating of the current date in cell B15 will be performed automatically each time you reopen the file.

The result of your actions is shown in fig. 70.

CONTENT

INTRODUCTION .................................................................................................................. 3

BASIC FUNCTIONALITIES OF THE EXCEL SPREADSHEETS ........................................... 4
  Structure of the Excel program Window ......................................................................... 4
  Worksheet structure ........................................................................................................ 5
  Ways of moving across the worksheet ............................................................................ 5
  Types of data in spreadsheet cells .................................................................................. 6
  Formats of data representation in cells .......................................................................... 6
  Creating, saving and opening of a workbook ................................................................ 7
    Creating and adjustment of a workbook ....................................................................... 7
  Workbook saving .......................................................................................................... 8
  Workbook opening ........................................................................................................ 9
  Data entering and editing .............................................................................................. 9
  Workbook editing .......................................................................................................... 10
  Optimization of work using templates ......................................................................... 11
  Working with blocks (ranges) of cells ........................................................................... 11
  Creating of formulas in a spreadsheet ......................................................................... 12
  Absolute and relative cells’ addresses .......................................................................... 13
  Methods of automatic change of the addresses in formulas while copying................ 13
  Functions in a spreadsheet ............................................................................................ 14
  Charts............................................................................................................................. 15
    Plotting charts ............................................................................................................ 15
    Data source change .................................................................................................... 18
    Adding and removal of chart elements ...................................................................... 19
    Changing of chart location ......................................................................................... 21

PRACTICAL TASKS ........................................................................................................... 22
  Practical task 1. Basic functionalities of the excel spreadsheets .................................... 22
    Exercise 1. Entering of various types of data into a spreadsheet ................................. 22
    Exercise 2. Creating formulas and using them for calculation .................................. 23
    Exercise 3. Built-in functions ...................................................................................... 24
    Exercise 4. Absolute references. Copying formulas with references ....................... 25
    Exercise 5. Spreadsheet editing .................................................................................. 26
    Exercise 6. Spreadsheet formatting ............................................................................ 26
  Practical task 2. Graphical representation of data. Charts .......................................... 28
    Exercise 1. Embedded charts ..................................................................................... 28
    Exercise 2. Charts formatting .................................................................................... 30
    Exercise 3. Charts editing .......................................................................................... 33
    Selfcontrol tasks ........................................................................................................ 35
  Practical Task 3. Graphical representation of data. Charts ........................................... 37
    Exercise 1. Plotting a graph illustrating the interdependence of values. A line graph .... 37
    Exercise 2. Line graph formatting ............................................................................ 38
    Exercise 3. Building several graphs on the same axes to illustrate the values of several variables ............................................................... 39
    Exercise 4. Plotting a graph illustrating the interdependence of values. scatter chart ... 40
    Selfcontrol tasks ........................................................................................................ 41
  Practical task 4. Optimization of work using templates ................................................. 42
    Exercise 1. Creating a standard report template ......................................................... 42
    Exercise 2. Formatting of a table template .................................................................. 43
    Exercise 3. Entering formulas .................................................................................... 44
    Exercise 4. Custom templates ..................................................................................... 46