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Chapter 1. BASIC DATABASE CONCEPTS 

DATABASE AND DATABASE MANAGEMENT SYSTEMS 

A database is an organized structure designed to store information. It 

means that databases store not only data, but also information. The concepts of 

data and information are interrelated, but they are not identical. The structure of a 

modern database can contain not only data itself, but also the methods by which 

this data should be processed and organized. 

Despite the fact that Office has a special application designed for work with 

databases (Microsoft Access), Excel also provides functions that allow users to 

create and edit databases, generate database reports and visualize information. 

Visualization means selection of the displayed data in accordance with a given 

criterion, its ordering, design and subsequent transfer to output devices (display, 

printer) or transfer via communication channels. 

Thus, Excel can be used for sorting or storing a small amount of data. 

STRUCTURE OF A SIMPLE DATABASE 

It should be noted that even if a database contains no data (a blank 

database), it is still a complete database, because it still contains information – the 

database structure. The database structure defines the methods of entering and 

storing of data. The simplest non-computer version of a database is a business 

diary, which has a separate page assigned to each calendar day. Even if there is no 

a line written in the diary, it is still a diary, because it has a structure that clearly 

distinguishes it from an ordinary notebook. 

Databases can contain different objects, but the main ones are tables. 

A simple database must contain at least one table. The structure of a two-

dimensional table is composed of columns and rows. Their analogues in the 

structure of a simple database are fields and records. If there are no records in the 

table yet, then its structure is formed only by a set of fields. 

In Excel, a simple database is called a table, its rows are called records, 

and the columns are called fields. The first row of a table must contain column 

headers that are used as field names (fig. 1). 
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Fig. 1. Example of records and fields in a database: 

1 — records (rows); 2 — fields (columns) 

TABLE (DATABASE) FIELD PROPERTIES 

Table (database) fields do not just form its structure, but they also define 

the group properties of the data written into the cells that belong to each of the 

fields. Changing the composition or properties of the fields of the basic table, we 

change the database structure, and thereby we get a new database. Let's specify 

the main properties of the list fields: 

– field name is the property that defines how to address the data of this field 

during automatic operations with the database; 

– field type is the type of data that can be contained in this field; 

– field format is the way of formatting of the data contained in the field cells. 

EXCEL TABLE COMMANDS 

To work with a table (list), the Data tab commands are used (fig. 2). 

 
Fig. 2. Data tab and its commands 

1 

2 
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Tables can be sorted in ascending, descending or user-defined order. The 

information within the table can also be filtered to display only the data that 

corresponds to a specified criterion. 

Excel has built-in data validation tools to work with tables. For example, 

the user can specify that a particular column of the table can contain numbers or 

dates only. 

Table cells can be formatted (font type, colour and size or colour fill) in the 

same way as the cells of a list. 

When working with tables, the user should use the Table tools tab (fig. 3), 

which appears after the cursor is set into any cell within the table. 
 

 

Fig. 3. Table tools tab and its commands 

TABLES OF EXCEL PACKAGE 

Excel tables (lists) provide tools that simplify management and analysis of 

groups of interrelated data on an Excel sheet. If you declare a range of cells to be 

a table, you can manage its data and analyze it regardless of data that was not 

included in the table. For example, you can filter the columns, add total rows, and 

create reports in the summary table using only the table data. 

One sheet can contain several tables, which let users divide the data flexibly 

into separate well-managed sets (fig. 4). 

The tables are differentiated by 

frames, which also allows users to 

distinguish the data of the table from the 

rest of the sheet data. 

When creating a table, the process 

of recognizing and modifying of its 

content can be simplified using the table 

tools and visual elements designed to 

improve these tools (fig. 5). They are as 

follows: 

1. By default, each column of the table can be modified with the 

AutoFilter. The buttons of the AutoFilter are situated in the title bar, which 

allows users to filter and sort the data quickly. 

2. The table indicator (a frame around the table) clearly marks out the cell 

interval that makes up the table. 

Fig. 4. An example of two different lists 

on one sheet 
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3. Users can add a Total row in a table (a special row, which contains a 

statistical function to process numeric data). If you click on any cell in this row, a 

drop-down list of generalized functions appears. 

4. The size of a table can be changed by dragging of the resize handler 

located in the lower corner of the table frame. 

 

 
 Fig. 5. Visual elements of a list: 

1 — AutoFilter; 2 — Table indicator; 3 — Total row; 4 — resize handler 
 

A table that is correctly organized should begin with the column headers. 

Each column must contain one and the same type of information. 

The data can be managed without organization of a table. However, 

creation of a table has many advantages and offers remarkable possibilities to 

calculate totals and process information. 

There are two ways to create a table. You can insert a table using the default 

table style, or convert the existing data into a table using the required style. 

CREATION OF A TABLE WITH A DEFAULT STYLE 

To create a table with a default style, follow these steps: 

1. Open a new workbook or a new worksheet. 

2. Create headers for each field of the list, set their alignment and format 

them as required. 

3. Format the cells under the headers according to the data that should be 

stored there (numeric formats), change the alignment, if necessary. 

4. Enter the data (records) under the headers. 

5. Select the range of cells that you want to include in the table. The cells 

can be either empty or contain data. 

6. On the Insert tab, in the Tables group, click the Table command (fig. 6), 

or press CTRL+L or CTRL+T.  

 

1 

2 

3 
4 
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Fig. 6. Creation of a table 

 

7. In the Format As Table window, set the check box My table has 

headers if the selected range contains the data that you want to use as the table 

header. If the check box My table has headers is clear, the table headers will 

display the default names only: Column 1, Column 2, etc. 

To change the default name, select the header and replace it with the 

required one. 

After the table is created, you can use the Table tools and the Design tab. 

The tools of the Design tab are used to adjust and modify the table. To make the 

Design tab visible, select any cell of the table. 

The table automatically extends its boundaries if you enter any data in the 

row following the table and in the column to the right of the table. To extend the 

boundaries of the table drag the resize handler (fig. 5) down or to the right. 

ADDING A TABLE WITH A SELECTED STYLE 

To create a table with a selected style, follow these steps: 

1. Select a range of cells with data (including the headers) that you want to 

convert quickly into a table. 

2. On the Home tab, in the Styles group, click Format as Table (fig. 7). 

3. In the Light, Medium or Dark section, click the desired table style. 

4. In the Create Table dialog box (see fig. 6), set the check box My table 

has headers if the selected range contains the data that you want to use for table 

headers. If the check box My table has headers is clear, the table headers will 

have default names Column 1, Column 2, etc. 

Note. When you select the command Format as Table, the table is inserted 

automatically. 

5. When the table is created, the Table Tools become available and the 

Design tab appears. Using the tools of the Design tab, you can configure and 

modify the table. 

If you set the Total Row check box in the Table Style Options group on 

the Table Tools tab, the total row will be added at the end of the table (list) 

(fig. 8). 
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Fig. 7. Creation of a table with a selected style 

 

Fig. 8. Adding the Totals row to a table 
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RECONVERSION OF A LIST INTO A RANGE OF CELLS  

If it is required, the table (list) can be converted back into a regular cells 

range. The data will remain on the Excel spreadsheet. To perform this procedure, 

do the following: 

1. Select any cell in the table. 

2. On the additional tab Table Tools, on the Design tab, find the Tools 

group, and select the command Convert to range. 

3. When a message with a request to convert the table in a regular range 

appears, click Yes. 

The data will no longer have special functions of the table. It will become a 

regular Excel data. No loss of information will occur after such a transformation. 

USE OF THE FORM 

MS Excel provides a powerful, convenient and simple tool designed to 

facilitate the entry of information into a table  which is the Data Entry Form. The 

Data Entry Form is a dialog box (fig. 9), which alternately displays the complete 

records. In the Data Entry Form they can be viewed, added, modified or deleted 

from the table. Also you can conduct search of the records that correspond to a 

specified criteria. 

If the database is empty (contains only headers of the fields), the data form 

displays all the column headers with an empty field next to each of them. These 

fields are intended for entering the 

data into the column. 

Excel generates a built-in 

data form for a table using the 

Form command. 

The data form is used if a 

simple column enumeration is 

enough and no more complex or 

customizable features are required. 

The data form can facilitate data 

entry, for example, when there is a 

wide list with the number of 

columns exceeding the number of 

columns that can be displayed on 

the screen at the same time. 

 

 

Fig. 9. Data Entry Form 
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OPENING OF THE DATA ENTRY FORM 

To open the Data Entry Form, follow these steps: 

1. Place the Form activation icon on the Quick Access toolbar: in the File 

menu, click Options  Quick Access Toolbar. In the left field Choose 

commands from... set the mode All Commands and click Form. Then click the 

Add button (fig. 10).  

Fig. 10. Adding of the Form command to the quick access toolbar 
 

2. In the right field of the Customize the Quick Access Toolbar the added 

command Form will appear. Click OK. 

3. Select any cell of the list. 

4. Click the Forms icon on the quick access toolbar. MS Excel will display 

the Form dialog box, shown in the Fig. 9. 

Each time the Form window will display the content of only one current 

record. 

ALGORITHM OF DATA ENTRY USING THE FORM 

To enter any data using the form do the following: 

1. Set the cursor into any cell of the list. 

2. Select the command Form. 

3. Click Add. 
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4. Fill the fields of a new record, using the Tab key to move to the 

following field. To return to the previous field use the key combination Shift + 

Tab. 

5. Press Enter to add the record into the list. 

6. After finishing entering the last record, click Close to add the entered 

record and close the form. Excel automatically adds the record after switching to 

another record or closing of the form. 

MS Excel does not allow entering data into the fields that contain formulas 

and automatically copies the formulas for calculation fields. 

When adding a record that contains a formula, the result of the formula will 

be calculated only after pressing the Enter key or clicking Close. 

MS Excel adds the record at the end of the data list. 

To cancel the addition of the record, click the Undo button before pressing 

Enter or clicking Close. 

ALGORITHM OF THE DATA DISPLAY AND RECORDS EDITING USING THE FORM 

By default the system displays only the first record, but the scroll bar and 

Find Prev and Find Next buttons allow the user to move on to the rest of the 

records and display the data. 

To edit the records using the form, do the following: 

1. Set the cursor into any cell of the list. 

2. Select the Form command. 

3. Find the record that should be edited. 

4. Edit the data of this record. 

5. Press Enter to update the current record and move on to the next one. 

Before that all the changes can be canceled by clicking the Restore button. 

6. After finishing editing, click Close to update the current record and 

close the form. 

SEARCH OF THE RECORDS IN THE TABLE (LIST) USING THE FORM 

To shift to one record, click the arrows of the scroll bar in the dialog box. 

To shift to 10 records, click the area between the arrows of the scroll bar. 

You may use the Find Next button to shift to the next record of the list and 

the Find Prev button to shift to the previous record. 

To specify search or comparison conditions (set of conditions for data 

search; the conditions may be represented by a required set of symbols, e. g. 

«Volkova» or an expression, such as «>300»), click Criteria and enter the criteria 

into the form. To search the records that match the criteria use the Find Next and 

Find Prev buttons. 
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ALGORITHM OF DELETING OF A RECORD USING THE FORM 

To delete a record using the form, do the following: 

1. Select any cell of the list. 

2. Select the Form command. 

3. Find the record that should be deleted. 

4. Click Delete. 

Deleting of a record using the form can not be canceled. 

SORTING DATA IN A TABLE 

After entering the data, you may need to arrange it. The process of 

arrangement of records in a database is called sorting. It allows the user to change 

the order of the records in a database, according to a specific task. The initial 

order of the records can be restored. The universal way to restore the initial order 

is the introduction of records’ sequence numbers. In combination with Excel's 

data recovery capabilities, it will completely protect the database against losses 

from accidental operational failures. 

To sort the records by one field, use the Ascending Sort  or 

Descending Sort commands that are situated on the Data tab in the Sort & 

Filter group. You can also use the AutoFilter icons. It allows the user to arrange 

the rows according to the contents of specific columns. 

It should be noted that the sorting result depends on the data type. To get 

the correct result, all cells of the column must contain the same data type, e. g. 

numbers or text. It is recommended to avoid the situations where the cells of one 

column contain both numbers and text.  

When you select the Sort command on the Data tab in the Sort & 

Filter group, the window Sort of the range appears (fig. 11).  
 

 

Fig. 11. Sort dialog box 
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This function allows the user to perform sorting by several fields. In this 

window, you can specify the sorting fields and determine its criteria. Using the 

drop-down list Sort By you can select the column for sorting. The order of sorting 

can be selected in the drop-down list. 

When sorting in ascending order, text data is arranged in alphabetical order 

from A to Z, while numeric data is arranged in increasing order from the 

minimum value to the maximum one. The dates are arranged from the earliest 

date to the latest one. 

When the records are sorted in descending order their arrangement is 

reversed. 

There are two additional sections Add Level 

and Copy Level that enable to define the order of 

secondary sorting. 

Sometimes it is required to select a range for 

sorting manually. If the selection includes the 

headers, set the check-box “My data has headers”, 

and clear this check box if it doesn’t (fig. 11). 

You can use up to 64 levels of sorting, and 

sort the data by the color of cells or font. 

The Sort dialog box contains the Options 

button, which enables to open the Sort Options 

dialog box (fig. 12). This dialog box allows to: 

– make sorting sensitive to uppercase and 

lowercase letters; 

– change the direction of sorting: by columns (sort top to bottom) or by 

rows (sort left to right). 

SIMPLE SORTING ALGORITHM 

To perform quick sorting of the table (list) data according to a certain 

column, do the following: 

1. Set the cursor in the sorted column. 

2. On the Data tab in the group Sorting & filter group click the 

Ascending Sorting icon  or Descending sorting icon . 

The sorting buttons are also available on the Home tab, in the Editing 

group. 

To cancel the sorting, click Undo on the quick access toolbar. 

RANGE SORTING ALGORITHM 

After the data was organized in a table (list), you can use the Sort command 

on the Data tab to rearrange or analyse the data. 

To sort the data range, do the following: 

1. Set the cursor in any cell in the table. 

Fig. 12. Sort Options dialog box 
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2. On the Data tab, in the Sort & Filter group select the Sort command. 

Now all data is selected and the Sort dialog box appears (see fig. 11). 

3. In the Column group, in the Sort by field, select the header of the 

column that should be used for sorting. 

4. In the Sort on field, select the type of sorting: 

– Values — sorting by values; 

– Cell Color — sorting by the color of the cell; 

– Font Color — sorting by the color of the font; 

– Cell icon — sorting by the set if icons. 

5. If you select sorting by cell color, font color, or cell icon in the Order 

group click the drop-down list and select the required cell color, font color, or 

cell icon. 

6. In the Order group, select the sequence of sorting: 

– to sort cells by their values, select the option: A to Z or Z to A (for 

symbolic data); Smallest to Largest or Largest to Smallest (for numeric data); 

Oldest to Newest or Newest to Oldest (for date values); 

– to sort cells by user-defined lists (e. g. sorting by the names of the months 

of the year), select the Custom List. When the List window opens, select the 

required list and click OK; 

– to sort cells by cell color, font color, or cell icon, select On Top or On 

Bottom. 

7. To sort by the next column, click Add Level, and then repeat the steps 3–

6. 

8. To delete sorting by a certain column, select its record and click Delete 

Level. The list must contain at least one column. 

9. Click OK. 

The columns with a higher position in the list will be sorted earlier than the 

columns with a lower position. 

To repeat sorting after changing the data on the Data tab, in the Sort & 

Filter group, click Reapply or press Ctrl + Alt + L. 

Do not forget that the maximum number of columns for sorting is 64. 

After application of sorting, the AutoFilter icon changes into the following 

way . 

To restore the original list, select the command Clear on the Data tab, in 

the Sort & Filter group. It will remove sorting for the current data range. 

DATA FILTERING 

Filtering is a quick and easy way to find a subset of the required data in a 

table. A filtered table displays only the rows that match the selection criteria 

specified for a column. Unlike sorting, filtering doesn’t change the order of 

records. It allows to hide temporarily the rows that don’t match the criteria. 
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The rows selected during filtering can be edited, formatted and printed. 

Also they can also be used for creation of diagrams without changing the order of 

the rows or moving them.  

There are two types of filters in MS Excel: AutoFilter and Advanced 

Filter. 

When using the AutoFilter, the filtering is performed directly on the initial 

data. When using the Advanced Filter, you can place the results of filtering in a 

separate area. 

In case of simple criteria, the AutoFilter is enough to display the required 

information. For complex criteria the Advanced Filter is used. 

When using the Find dialog box for search in the filtered data, the search is 

performed only among the displayed data, while the hidden data is not involved. 

FILTERING OF DATA USING THE AUTOFILTER 

The AutoFilter allows creation of three types of filters: by list of values, 

by format or by conditions. All of them are mutually exclusive within the range 

of cells or the column of the table. For example, you can perform filtering by cell 

color or by a list of numbers, but you can not use both types of filters at the same 

time. Likewise you need to select only one option if you want to perform selection 

by icons or apply a custom filter. 

As it was mentioned above, the AutoFilter is applied by default to each 

column of the table. The buttons of the AutoFilter are located in the title bar 

(fig. 13). 

The presence of this button indicates that filtering is enabled, but not 

applied. 

You can enable or disable the AutoFilter by clicking the Filter button   

on the Data tab, in the Sort & Filter group.  

After clicking the AutoFilter button, the full list of the field data is opened 

(fig. 14). 

Fig. 13. The AutoFilter button 
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Fig. 14. The use of the AutoFilter 

 

When you select a specific value, all rows that contain this value in the 

selected field are displayed. For example, you can view data only for a particular 

drug (fig. 15). 

Fig. 15. The result of the use of the AutoFilter 

If the AutoFilter icon has changed its appearance , it means that a filter 

has been applied to this field. 

To restore the initial list set the check box Select all in the AutoFilter list 

or select the Clear command on the Data tab, in the Sort & Filter group. It will 

remove all filtering conditions and sorting for the current data range. 

APPLICATION OF CUSTOM CRITERIA 

Another way of filtering data in a table (list) is the application of custom 

comparison criteria. 

To perform filtering based on certain conditions follow these steps: 

1. Select any cell in the table (list). 

2. Click the AutoFilter button next to the header of the column that should 

be used for filtering (if the AutoFilter button is absent, click the Filter button on 

the Data tab, in the Sort & filter group). 
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3. Do one of the following operations: 

– if the column contains text data, select the Text Filters command (fig. 16, 

a); 

– if the column contains numbers, select the Number Filters command 

(fig. 16, b). 
 

 
a 
 

 
b 
 

Fig. 16. Filtering commands of the AutoFilter: 

а — Text Filters; b — Number Filters 
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To obtain better results, do not mix different types of data in one column 

(e. g. text and numbers or numbers and dates), because only one type of filtering 

commands is available for each column. 

If the column contains different types of data, the AutoFilter will display 

the filter command for the type of data that occurs more often. For example, if the 

column contains four textual values and nine date values, the Date Filters 

command is displayed. 

3. Select the appropriate filter criterion (Equals...; Does Not Equal...; 

Begins With...; Ends With...; Contains...; Does Not Contain..., etc.) or the 

Custom Filter command. MS Excel will display the Custom AutoFilter window 

(fig. 17). 

Fig. 17. Custom AutoFilter window 
 

In this window, you can define one or two comparison criteria for one and 

the same column. Excel will compare the elements of the list with the values 

entered in the dialog box and display only the rows that met the given criterion. 

To combine or compare criteria for one and the same column, you can use the 

AND/OR operators. 

In the Custom AutoFilter window find the field Show rows where. It 

displays the header of the column that contains the active cell (selected with the 

cursor), and two fields with drop-down lists. To enter one criterion, one line is 

used. The button at the right edge of the field opens the list of comparison 

operators that can be used for entering of a criterion (fig. 18). 
 

 

Fig. 18. The list of comparison operators 
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Do one of the following actions in the field to the right of the comparison 

operator field: 

1. Enter the value that you want to use for comparison. 

2. Click on the arrow, and select the value that you want to use for 

comparison. 

The second set of drop-down lists is used to indicate another comparison 

operator and the value to be used with this operator. 

If the switch key AND is selected, Excel will display only the rows that 

match each of the two criteria. If the switch key OR is selected, Excel will display 

the rows that match at least one criterion. 

To expand the search capabilities, the wildcard symbols «?» and «*» can be 

used. To pick out the rows with cells containing a sequence of characters, certain 

positions of which can contain different characters, you need to take into account 

the following rules: 

– «?» (the question mark) can replace a character (e. g. the notions «cat» 

and «cut» correspond to the condition «c?t»); 

– «*» (the asterisk) replaces any number of characters (e. g. the notions 

«elephant» and «eye» correspond to the condition «e*», etc.). 

To reapply the filter after changing the data, select the cell in the range or 

table, and click Reapply on the Data tab, in the Sort & Filter group. 

All date filters are based on the Gregorian chronology. 

The fiscal year and fiscal quarter always begin in January of the calendar 

year. 

If you want to filter cells by the days of the week, change their format so 

that the days of the week are displayed. 

CANCEL OF FILTRATION 

To display all the data in the list, do the following: 

1. Click the AutoFilter button next to the header of the filtering column. 

2. Do one of the following operations: 

– in the drop-down list select the command Clear Filter From (the column 

name); 

– set the check box Select All in the AutoFilter list; 

– if you used more than one column for filtering, you can cancel the 

filtering by clicking the Clear button on the Data tab, in the Sort & filter group. 

APPLICATION OF THE ADVANCED FILTER 

The Advanced Filter command was designed to search database records 

using more complex criteria as compared to custom filters. 

There are two types of criteria: multiple and calculated. Multiple criteria are 

used when you need to define more than two comparison criteria for a single 
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column. Calculated criteria are applied 

when the comparison operations contain 

any calculation results. 

To filter the data the criteria interval 

should be specified. Excel displays only 

the rows that match all recorded criteria in 

the range. The filter parameters should be 

specified in the Advanced Filter dialog 

box (fig. 19). 

The Action section contains the 

switch keys Filter the list, in-place and 

Copy to another location. If you select 

the first switch key, Excel displays only 

the rows that match the specified criteria. 

If you select Copy to another location, the filtered data is copied to another 

location on the same spreadsheet. 

The List range field is the interval that contains the list to be filtered. Here 

you need to enter the link to the table. 

In the Criteria range field you need to specify the cell range that contains 

the filtering criteria. The Criteria range must be created before using the 

advanced filter. This range should consist of at least two rows, the first of which 

contains the headers of the list fields that you want to use for filtering, while the 

others should contain user-defined conditions. The range of conditions can be 

located anywhere in the spreadsheet or even on a separate spreadsheet. 

In the Copy to field you can specify the interval of cells where you want to 

copy the rows that meet the criteria. This field is active only if the Copy to 

another location check box is set. 

The Unique records only check box is used to display only non-repeating 

rows. 

Creation of the Conditions Range. 

To set up a Conditions Range, follow these steps: 

1. Copy the headers of the columns with the data to be restricted in a blank 

row outside the table. 

2. Set conditions of data selection under each of the headers: 

– conditions may be represented by data or data elements, contain 

comparison operators (more or less), or they can be formulas, e.g. a formula that 

filters all values that exceed the average value of the column; 

– conditions may contain wildcards «?» or «*»; 

– the conditions located in one row are considered as conditions combined 

by the operator AND (fig. 20, a); 

– the conditions located in different rows are considered as conditions 

combined by the operator OR (fig. 20, b). 

Fig. 19. Advanced Filter dialog box 
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а 

б 
 

Fig. 20. Conditions Range: 

a — AND connective; b —OR connective 
 

There must be at least one blank row (column) between the database 

table and the range of conditions. 

Creation of the Advanced Filter. 

To perform filtering using the Advanced Filter, follow these steps: 

1. Select any cell inside the table (list). 

2. On the Data tab, in the Sort & Filter 

group, click the Advanced button. The 

Advanced Filter dialog box will open 

(fig. 21).  

3. In the Advanced Filter dialog box, 

in the Action section, do one of the following: 

– to display the results of filtering 

directly in the list and hide the rows that do 

not meet the selection criteria, set the check 

box Filter the list, in-place; 

– if the result of filtering should be 

placed elsewhere on the same spreadsheet, et 

the check box Copy to another location. 

 

Fig. 21. Setting up the parameters 

of the Advanced Filter 

 

Criteria range 

 

Criteria 

range 
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4. In the List range field specify the range of cells to be filtered. The range 

must contain all cells in the list and the cells of the column headers. 

5. In the field Criteria range specify the range of previously formulated 

conditions: it must contain all cells in the range of selection conditions and the 

cells of the column headers. 

6. In the field Copy to specify the cell from which the Result Range will 

begin on the sheet. This field is active only if the Copy to check box is set. The 

result range can only be placed on the same spreadsheet with the original range. 

7. Click OK to complete the filtration. Excel will display only those records 

that meet the specified criteria (fig. 22). 
 

Fig. 22. The result of application of the Advanced Filter 

HIDING AND DISPLAYING OF THE INFORMATION IN A TABLE 

If the table (list) contains cells with unnecessary information that impedes 

data analysis, you may hide certain columns or rows. You may also use this 

function if you want to print a table and exclude unnecessary rows or columns. 

Hiding of the elements of the table does not lead to their removal, they just are not 

displayed on the screen. This process is reversible, as all the elements of the table 

can be displayed on the screen at any time. 

The rows and columns can be hidden in two ways: by adding the «hidden» 

attribute or by grouping. 

USE OF THE HIDDEN ATTRIBUTE  

To hide the elements of a table, do the following: 

1. Select the column, row or group of columns and rows. 

2. On the Home tab, in the Cell group, click Format. In the Visibility 

section of the Format command drop-down list, click Hide & Unhide (fig. 23). 

Criteria range 

 

Filtration result 
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Fig. 23. The drop-down list of the Format command 

To display hidden elements, do the following: 

1. Select the area of hidden columns or rows. 

2. On the Home tab, in the Cell group, click Format. In the Visibility 

section of the Format command drop-down list, click Hide & Unhide. 

GROUPING OF ROWS AND COLUMNS 

Sometimes you have to work with huge tables, consisting of hundreds of 

rows and/or columns with data which can be logically combined into groups. For 

this purpose MS Excel has the data grouping tool, which allows the user to create 

a multilevel structure. The structure can be composed of rows, columns or both 

rows and columns at the same time.  

The data on a spreadsheet can be structured automatically or manually. 

Manual data structuring doesn’t presuppose any special requirements for 

data structure. 

If you need to group levels manually, display all the data on the screen to 

avoid errors. Then do the following: 

1. Select all the rows (columns) that should be combined into a group. 

2. Groups of detailed data should be separated either by blank rows 

(columns) or by the result rows (columns). 

Do not include the result row or a blank row used to separate data groups 

into selected area. 
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3. On the Data tab, in the Outline group, click the Group button. 

If you’ve selected not whole rows (columns), 

but a range of cells, the Group dialog box will 

appear (fig. 24). In this window you should specify 

the elements that you want to group — rows or 

columns. 

Next to the group the structure signs will appear. 

4. Continue selecting and grouping the internal 

rows (columns) until all the necessary levels of the 

structure will be created.  

Automatic data structuring presupposes that 

the data should contain total rows (or columns) located next to the detailed data. 

These total rows (or columns) must include final formulas with references to the 

cells located within the data range. 

HIDING AND DISPLAYING OF STRUCTURED DATA 

Displaying of the outline symbols on a spreadsheet. If there are no 

outline symbols ( , , , etc.) on the spreadsheet, do the following: 

1. On the File tab click the Options command. 

2. On the Advanced section, in the group Display options for this 

worksheet select the sheet that contains structured data. 

3. Set the check box Show outline symbols if an outline is applied 

(fig. 25). 

Displaying or hiding of the detailed data of a group. To manage 

individual groups, do one of the following actions: 

1. To display the group details, click the button  that corresponds to that 

group. 

2. To hide the group details, click the button  that corresponds to that 

group. 

Displaying or hiding of the outline to a certain level. 

To manage all groups of a certain level, do the following: among the 

outline symbols  click the button with the number of the required level. 

Details of the lower levels will be hidden. For example, if the outline consists of 

four levels, you can hide the fourth level by pressing the button , while the 

remaining three levels will be displayed. 

Displaying or hiding of all structured data. 

To display all details, press the lowest level button of the outline symbols 

. For example, if there are three levels in the outline, click the button . 

To hide all details, click the button . 

 

Fig. 24. Group dialog box 
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Fig. 25. Settings of the outline symbols displaying 

DATA UNGROUPING 

If necessary, you can cancel multilevel structuring of data. In addition, you 

can cancel the grouping of separate outline elements, as well as separate rows 

(columns). 

Deletion of a multilevel structure. 
To cancel a multi-level structure, follow these steps: 

1. Select any cell within the multi-level structure. 

2. On the Data tab, in the Outline group, click the arrow to the left of the 

Ungroup button and select Clear Outline. 

Ungrouping of separate elements of a multilevel structure. 

To ungroup elements of a multi-level structure, follow these steps: 

1. Select the elements of the multi-level structure that should be excluded 

from the group. 

To select all the elements of the group, hold down the Shift key and click 

buttons  or  that correspond to that group. 

2. On the Data tab, in the Outline group, click Ungroup. 

If the detailed data is hidden during the ungrouping of the multi-level 

structure, the columns that contain this hidden data can be hidden as well. To display 

the data, drag the pointer through the numbers of visible columns (rows) next to 
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hidden columns (rows). On the Home tab, in the Cells group, click Format, select 

Hide & Unhide, and then click Unhide Columns (Unhide Rows). 

Ungrouping of rows (columns). 
To ungroup rows (columns), follow these steps: 

1. Select the rows (columns) that you want to ungroup. 

2. On the Data tab, in the Outline group, click Ungroup. 

SUMMARIZING 

CREATION OF TOTALS 

One of the ways to process and analyze a table (list) is summarizing. 

On the Additional tab Table Tools\Design, set the Total Row check box 

(fig. 26). 

Under the table (list), Excel will add a new row with the word Total, which 

shows total results for the selected column. This mode allows the user to display 

automatically the totals for each column of the table. 

To calculate the grand total in any column, you should simply place the 

cursor in the total row of a particular column and select the required final formula 

from the list (fig. 26). 
 

Fig. 26. Adding the Total Row 
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If the data is organized as a table (list), you can use the automatic summing 

up function using the Subtotal command. The operation of automatic 

summarizing of subtotals in MS Excel not only calculates totals and transfer them 

to the worksheet, but simultaneously creates on the worksheet an outline 

associated with the resulting totals. 
Note. The Subtotal command is not available when working with the Microsoft Excel 

spreadsheet. To add subtotals to the table, you must first convert it to a normal data range. Note 

that it will lead to removal of all functional capabilities connected to the tables, except for 

formatting. 

To calculate simple subtotals, follow these steps: 

1. Perform sorting by the column that want to sum up, so that all the records 

of this column with the identical fields fall into one group. For this purpose: 

– set the cursor in any cell of the column that you want to sum up; 

– on the Data tab, in the Sort & Filter group, click the Sort Largest to 

Smallest  or Sort Smallest to Largest  buttons. 

2. On the Data tab, in the Outline group, click the Subtotal button. 

MS Excel will display the Subtotal dialog box (fig. 27). 

3. In the field At each change in, select 

the column by which the data was sorted (see 

point 1).  

4. In the field Use function, select the 

function to calculate the totals. The list of the 

main available functions is presented in the 

Table 2. 

By default, MS Excel uses the Sum 

function for numeric values and the Number 

function for text values. 

5. In the field Add subtotal to, set the 

check boxes next to the names of the columns 

to be calculated. 

6. If necessary, set or clear the check 

boxes with different parameters. The list of 

parameters of the Subtotal dialog box is shown 

in the Table 3. 

7. Click OK. 

After summarizing the subtotals, the table is represented in the form of an 

outline, which allows the user to display or hide the rows of each subtotal result 

(fig. 28). 

To display only subtotals and the grand total you may use the outline level 

icons  on the left side of the screen (next to the row numbers). 

Buttons  and  allow the user to show and hide the rows with details for 

particular totals. 

Fig. 27. Subtotal dialog box 
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Fig. 28. An example of a table with a Subtotal result 
 

The subtotals can be reapplied to a table that has been already processed. 

To increase flexibility, you can add details levels to an outline created in 

Excel. It allows the user to hide certain details, if necessary. For example, you can 

hide the information of one group in order to view the details of other groups and 

compare them to each other. 
Table 2 

Main functions available in the Use function field 
Function Description 

Sum The sum of values. This operation is used by default to summarize 

numeric fields 

Count Number of records and data rows. This operation is used by default to 

summarize non-numeric fields 

Average Average number 

Max Maximal number 

Min Minimal number 

Product Products of numbers 

Count Numbers Number of records and rows containing numbers 

 

Table 3 

Additional parameters of the Subtotal dialog box 
Parameter Description 

Replace current subtotals Recalculating of subtotals and replacement of current ones 

Page break between 

groups 

Inserting of automatic page breaks after each group of subtotals 

Summary below data Insertion of subtotal rows and grand totals below data 

Remove All Removal of subtotal 

REMOVAL OF SUBTOTALS 

To display the table (list) in its original form, you need to delete subtotals. 

For this purpose, do the following: 

1. Select any cell in the range that contains subtotals. 
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2. On the Data tab, in the Outline group, click the Subtotal button. 

3. In the Subtotal dialog box, click the Remove All button. MS Excel will 

delete all subtotals. 
 

 

Chapter 2. PRACTICAL TASKS 

CREATION OF A SIMPLE DATABASE 

DATA INPUT 

Use the given data to create a database of patients with ischemic 

cardiomyopathy and metabolic syndrome according to the sample in fig. 29. 

Fig. 29 

For this purpose do the following: 

1. Run Excel. 

2. Create a new workbook and save it under the name ICMS Database. 

3. Rename Sheet1 as ICMS. 

4. Fill the table with data about the patients according to the fig. 34. 

CREATION OF A TABLE BASED ON THE GIVEN DATA 

To ensure that Excel interprets the input data as a table, do the following: 

1. Select any cell with data and click Table on the Insert tab. 

2. In the Format as Table dialog box (fig. 30) set the following parameters: 

– use the mouse to select the range of cells A2:H10 and create a list on its 

basis; 

 

 

 

 

 
 

Fig. 30. Format as Table dialog box 



 30 

– set a check box to confirm that the table contains column headers; 

– Click OK.  

The result of these actions is shown in the fig. 31.  

Now the data is organized as a table, and the AutoFilter buttons are 

automatically added to the title bar of each column. A frame with a resize handle 

appears around the list. The frame shows the range of cells in the list. 

Fig. 31. ICMS Database 

After creation of a table, the Table Tools become available and the Design 

tab appears. The Design tab allows the user to configure and modify the table. 

CONVERSION OF A TABLE INTO A REGULAR RANGE OF CELLS 

To convert a table into a range of cells, do the following: 

1. Select any cell in the table. 

2. On the Table tools\Design tab, in the Tools group, select the command 

Convert to Range. 

3. In the appeared dialog box confirm the conversion of the table into a 

regular range by pressing the button Yes. 

The data no longer have any special functions specific for a table. Now it is 

a regular Excel data. 

 

Exercise 1. Convert the data about the group of patients with ischemic 

cardiomyopathy and metabolic syndrome into a table. 

EDITING AND UPDATING OF A DATABASE: 

ENTERING FORMULAS. INSERTING RECORDS AND FIELDS 

As it is known, the body mass index (BMI) is one of the informative 

indicators that can be used as a risk factor for pathology development. It is 

calculated as follows: BMI = mass/height
2
. 
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Insert another column (field) in the table to calculate the BMI, enter the 

formula to calculate it. For this purpose do the following: 

1. Set the cursor in the column G, as new columns are inserted to the left of 

the active cell. 

2. On the Home tab, in the Cell group, click Insert  Insert Sheet 

Columns. 

3. Rename the inserted column Column1 as BMI. 

4. Enter the BMI formula in cell G3. 

To enter the formula, use the method of cursor indication. In this case, 

during entering of the formula Excel will display not the names of the cells, but 

the names of the fields: = [@ weight]/[@height]^2. After pressing Enter the 

formula will be automatically copied to all elements of the table. In case of 

regular typing (=F3/E3^2), you will need to copy the formula from cell G3 to 

cells G4:G10. It is more convenient to use the AutoFill marker. 

– set the cursor in cell G3; 

– point the cursor to the lower right corner of cell G3 until the AutoFill 

marker + (plus) appears, then hold the left mouse button and simultaneously drag 

the selection downwards to cell G10. 

5. Round the result in cells G3:G10 to an integer value using the Decrease 

Decimal button on the Home tab, in the Number group. 

The result of these actions is shown in fig. 32. 
 

Fig. 32 Addition of the calculated BMI 

6. Enter additional information about the patients as shown in the fig. 33: 

– set the cursor in cell A11, type «Singh», press Tab or  to move to the 

next cell; 

– type «Arosh» in cell B11, press the Tab key or  to move to the next cell; 

– fill all the cells in the same way. 

Fig. 33 Additional information in the database 

After entering the growth and weight data of a patient, the BMI will be 

calculated automatically using the formula. 
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WORK WITH THE FORM: VIEWING AND EDITING 

OF THE DATABASE RECORDS USING THE FORM 

Use the Form to review the contents of the database and edit it in the 

following way: 

– change the record of the Status field of the patient Adam Wood to 

«discharged»; 

– enter additional records (patients’ data) as it is shown in the fig. 34. 

Fig. 34 

For this purpose do the following: 

1. Specify any cell in the table (in the range A2 : I12). 

2. On the Quick Access Toolbar, click the Form command. If the Form 

command is not available on the Quick Access Toolbar, you must add it 

(see 1.6.1). 

3. To view the content of the list using the form (fig. 35), click the Find 

Prev and Find Next buttons. 

4. To edit the 9
th

 record, do the following:  

– use the Find Next button to move to the 9
th
 record of the patient Wood; 

– replace the text in the Status field to «discharged»; 

– press Enter to update the record. 

5. To add new rows, do the following: 

– in the form window, click Add; 

– fill in the fields of the new 11
th

 record of the patient Petrov; 

– press Enter to add a new record to the list; 

– enter the data of the patient Wong in the 12
th

 record; 

– click the Close button to add a row which will the last one in the list. 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Fig. 35 
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The result of these actions is shown in the fig. 36. 

Fig. 36 

DATABASE SORTING 

SORTING OF A DATABASE BY ONE FIELD 

Arrange the data. 

Change the order of the records so that the patients’ surnames are arranged 

alphabetically. Then, sort the BMI values in descending order. 

For this purpose do the following: 

1. Sort the data in the Surname column: 

– click the AutoFilter arrow in the Surname field and select the icon   

(Ascending Sort) in the appeared menu; 

– analyze the results (the first record in the list must be Abadi, the last 

record must be Wood). 

2. Copy the result of sorting in the range of cells starting from A19. 
 

Exercise 2. Arrange the data in the BMI column in descending order (Sort 

Z to A command). Make sure that the first patient on the list is Singh, who has a 

BMI = 38, and the last one is Fedotova with BMI = 20. Copy the result of sorting 

in the range of cells starting from A36. 

SORTING OF THE DATABASE BY MULTIPLE FIELDS 

Sort the list in ascending and descending order. 

Change the order of the records so that women go first, followed by men. 

Both categories should be displayed in age decreasing order. To do this, you need 

to organize the data by the values of the fields Gender and Age. 

As it was mentioned earlier, the table may be sorted by multiple fields, 

which makes sense when data can be divided into groups (e. g. men and women). 
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In this case, you can sort data by another field within these groups. The columns 

with a higher position in the list will be sorted earlier than the columns with a 

lower position. 

To sort the contents of several columns simultaneously, follow these steps: 

1. On the Data tab, in the Sort & Filter group, select the Sort command 

. 

2. In the Sort dialog box (fig. 37), specify the fields for sorting: 

– in the first level area of Sort by, in the Column section select the field 

name Gender, in the Sort on section select Values, in the Order section select A 

to Z (ascending order); 

– click the Add Level button; 

– in the second level area Then by, in the Age field, in the Sort on and 

Order sections, select Values and Z to A (descending order), respectively. 

Fig.  37 

 

The result is shown in the fig. 38. 

 

 

 

 

 

 

 

 

 

Fig. 38 
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As a result of sorting by two fields Gender and Age, the data in the table is 

divided into two groups: women and men. The records within the groups are 

arranged in age decreasing order. 

Copy the result of sorting in the range of cells starting from A53. 
 

Exercise 3. Change the order of the records so that women go first, 

followed by men. Both categories should be displayed in alphabetical order of 

surnames. Make sure that the first patient of the list is the patient Chan, while the 

last one is Wood. Copy the result of sorting in the range of cells starting from cell 

A70. 

APPLICATION OF THE AUTOFILTER: 

DATA FILTERING 

Display on the screen the information about the patients treated by 

Dr. Bakun. Then display the list of female patients of Dr. Demchenko. 

Data filtering is as easy as sorting. Just click the AutoFilter arrow and select 

the required option. Excel will automatically display the selected data only. 

To filter the data, do the following: 

1. To view the data of Dr. Bakun’s patients, click the AutoFilter arrow of 

the Doctor in Charge field and select the option Bakun. The result of your 

actions is shown in the fig. 39. 

Fig. 39 

Regardless of the column that contains the selected data, Excel displays 

only the filtered rows in all the columns of the list. 

Copy the result of filtering into the range of cells starting from cell K19. 

2. To return the list to the initial state, click the AutoFilter arrow of the 

Doctor in Charge field again and click Select all. 

3. To filter the contents of several columns simultaneously, do the 

following: 

– click the AutoFilter arrow of the Gender field and select option f (the list 

of female patients will be displayed); 

– in the list that is already filtered, click the AutoFilter arrow of the Doctor 

in Charge field and select Demchenko. 

The list will shorten to six rows, as it is shown in the fig. 40. 
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Fig. 40 

4. Copy the result of filtering into the range of cells starting from cell K28. 

5. To return the list to the initial state, click the AutoFilter arrows of the 

Gender and Doctor in Charge fields again, then click Select all in both cases, or 

on the Data tab, in the Sort & Filter group, click Clear. 

 

Exercise 4. Display on the screen the information about male patients 

treated by Dr. Demchenko. Copy the result of filtering into the range of cells 

starting from cell K37. 

APPLICATION OF USER CRITERIA 

APPLICATION OF THE CUSTOM FILTER WITH ONE CRITERION 

Create a custom filter to display the list of men of retirement age (65 years 

and older). 

For this purpose do the following: 

1. Click the AutoFilter arrow of the Gender field and select m (Excel will 

display the list of male patients). 

2. Click the AutoFilter arrow of the Age field and select the Number 

Filters option  Greater Than Or Equal To. 

3. In the Custom AutoFilter dialog box that appears (fig. 41), specify the 

selection criteria: 

– in the text field to the right, type 65; 

– click OK. 

Fig. 41 
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The list will shorten to one record, as it is shown in the fig. 42. 

Fig. 42 

 

4. Copy the result of filtering into the range of cells starting from cell K44. 

5. To return the list to the its initial view, click the AutoFilter arrows of the 

Gender and Age fields again, then click Select all in both cases, or on the Data 

tab, in the Sort & Filter group, click Clear. 

 

Exercise 5. Create a custom filter to display the list of women whose height 

is more than 1.64 m. Copy the result of filtering into the range of cells starting 

from cell K48. 

APPLICATION OF THE CUSTOM FILTER WITH TWO CRITERIA 

It is well known that if the BMI value is equal to 26–29, it is considered as 

overweight, and if it is equal to 30 or more, it is considered as obesity. Create a 

custom filter to display the list of patients with overweight (26 ≤ BMI < 30). 

For this purpose do the following: 

1. Click the AutoFilter arrow of the BMI field and select the Number 

Filters  Custom Filter. 

2. In the Custom AutoFilter dialog box, specify the selection criteria: 

– in the BMI field select is greater than or equal to; 

– in the text field to the right, enter the value «26»; 

– select the AND operator (the AND operator presupposes presence of all 

the listed conditions in the selected records, while the OR operator presupposes 

presence of at least one condition); 

– in the second drop-down list, select one more criterion – is less than; 

– in the text field to the right, enter the value «30» (fig. 43); 

– click OK. 

 

Fig. 43 
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The result of filtering is shown in the fig. 44. 

Fig. 44 

3. Copy the result of filtering into the range of cells starting from cell K53. 

4. To return the list to its initial view, click the BMI AutoFilter arrow and 

click Select all or on the Data tab in the Sort & Filter group, click Clear. 

 

Exercise 6. Create a custom filter to display the list of patients aged 50 to 

60, copy the result of filtering into the range of cells staring from cell K58. 

APPLICATION OF THE ADVANCED FILTER 

Copy the initial database to Sheet 2, using the Special Insert. Rename the 

sheet as Advanced Filter. 

ADVANCED FILTER WITH SEVERAL CONDITIONS FOR ONE COLUMN 

Find the database records about the in-patients who do not continue 

treatment. 

If there are two or more selection conditions for one column, enter these 

conditions directly under each other in separate rows. 

For example, this range of selection conditions displays rows 

that contain the values «discharged» or «died» in the Status column. 

To filter the data, do the following: 

1. Create selection criteria: 

– place the cursor in cell A18, as there must be at least one empty row 

between the values of the conditions and the range of conditions; 

– type the name of the column «Status» in cell A18, as the range of 

conditions should include column headers; 

– enter the selection criteria: type «discharged» in cell A19, and «died» in 

cell A20. 

2. On the Data tab, in the Sort & Filter group, click Advanced.  

3. In the Advanced Filter dialog box (fig. 45), specify filter parameters. For 

this purpose do the following: 

– to copy the filtered rows to another area of the worksheet, set the check 

box Copy to another location in the Action field, press the Tab key; 

– in the List range field, select with the mouse the table with the data or 

type absolute references to the range of cells $A$2:$I$14, press the Tab key; 

Status 

discharged 

died 
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– in the Criteria range field, select the interval that contains the selection 

criteria A18:A20, or type absolute references to the range of cells $A$18:$A$20, 

press the Tab key; 

– in the Copy to field, select the upper left cell of the insertion area A22; 

– Click OK. 

 
 

 

 

 
 

Fig. 45 

The result of these actions is shown in the fig. 46. 
 

 

 

 

 

 

 

 

Fig. 46 

ADVANCED FILTER WITH A SINGLE CONDITION FOR MULTIPLE COLUMNS 

Find the records of doctor Bakun’s male patients, whose weigh is more than 

110 kg. 

In order to find the data corresponding to one and the same selection 

condition in several columns, enter all selection parameters in one row of the 

range of selection conditions. 

For example, this range of selection 

conditions will display all the rows that contain 

the values «m» in the column Gender, «Bakun» in the column Doctor in charge 

and «>110» in the column Weight (i. e. all the criteria are combined by the 

connective AND, and the presence of all selection conditions in the output records 

is obligatory). 

Gender Weight Doctor in Charge 

m >110 Bakun 
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To filter the data, do the following: 

1. Create selection criteria: 

– enter the name of the column «Gender» in cell K2, the name of the 

column «Weight» in cell L2, and the name of the column «Doctor in charge» in 

cell M2; 

– enter the selection criteria: the value «m» into cell K3, «>110» in cell L3,  

«Bakun» in cell M3. 

2. On the Data tab, in the Sort & Filter group, click Advanced.  

3. In the Advanced Filter dialog box, 

specify filter parameters: 

– in the Action field, click the Copy to 

another location, press the Tab key; 

– in the List range field, select the table 

with the data (or type the range of cells 

$A$2:$I$16), press the Tab key; 

– in the Criteria range field, select the 

interval containing the criteria (or type the range 

of cells $K$2:$M$3), press the Tab key; 

– in the Copy to field, click indicate the 

address K5 (fig. 47); 

– Click OK. 

The result of these actions is shown in the fig. 48. 

Fig.  48 

ADVANCED FILTER WITH DIFFERENT CONDITIONS FOR DIFFERENT COLUMNS 

Find the records of Dr. Bakun’s female patients, all patients whose weigh is 

more than 110 kg, and all patients treated by Dr. Bakun. 

In order to find data that corresponds to one condition in one column or 

satisfies another condition in another column, enter the selection conditions in 

different rows of the range of selection conditions. 

For example, this range of selection conditions 

displays all the rows that contain the value «f» in 

the column Gender, the value «Dr. Bakun» in the 

column Doctor in charge or the value «>110» in 

the column Weight. 

 

Gen
der 

Weig
ht 

Doctor in 
charge 

f   

 >110  

  Bakun 

Fig. 47 
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To filter the data, do the following: 

1. Create selection criteria: 

– enter the name of the column «Gender» in cell K11, the name of the 

column «Weight» in cell L11 and the name of the column «Doctor in charge» in 

cell M11; 

– enter the selection criteria: the value «f» in cell K12, the value «>110» in 

cell L13 and the value «Dr. Bakun» in cell M14. 

1. On the Data tab, in the Sort and Filter group, click Advanced. 

2. In the Advanced Filter dialog box, specify filter parameters: 

– in the Action field, set the check box Copy to another location, press the 

Tab key; 

– in the List range field, select the table with the data (or type the range of 

cells $A$2:$I$16), press Tab; 

– in the Criteria range field, select the interval that contains the criteria (or 

type $K$11:$M$14), press Tab; 

– in the Copy to field, indicate the address K16; 

– click OK; 

The result of these actions is shown in the fig. 49 

Fig.  49 
 

Exercise 7. Find the records of female patients whose weigh is more than 

90 kg, and male patients whose weight is more than 110 kg. Insert the created 

filter into cell K30, and place the result in cell K34. 

ADVANCED FILTER WITH A CONDITION THAT REQUIRES ANY CALCULATION 

Create a filter that will display the list of patients whose BMI exceeds the 

calculated average. 

The selection condition can be represented by the value resulted from a 

formula calculation. If you enter a selection condition using a formula, leave the 

condition without a title, or use a header that is not the header of the column in 

the list. For example, this range of selection conditions displays the rows that 
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contain in the column G a value that exceeds the average value of the cells in the 

range G3:G14. 

The formula for creation of the selection condition must contain a relative 

reference (format «G3») to the column header (e. g.: BMI) or to the 

corresponding field in the first record. All other references must be absolute 

(format «$G$3»), and the formula must have the result TRUE or FALSE. In the 

example above, «G3» is a reference to column G of the third row of the list. 

To filter the data, do the following: 

1. Create selection criteria: 

– enter the selection condition: leave cell 

A34 blank, enter the formula: =G3>AVERAGE($G$3:$G$16) in cell A35. Use 

the mouse to specify the range G3:G14 and the F4 function key to make the 

references G3 and G14 absolute. 

2. On the Data tab, in the Sort & Filter group, click Advanced. 

3. In the Advanced Filter dialog box, specify the filter parameters: 

– set the check box Copy to another location, press the Tab key; 

– in the List range field, select the table with the data using the mouse (or 

type the range of cells $A$2:$I$16), press the Tab key; 

– in the Criteria range field, select the range of cells containing the 

criterion A34:A35, press the Tab key; 

– in the Copy to field, click the address A37; 

– Click OK. 

The result of selection is shown in the fig. 50. 

Fig. 50 
 

The BMI average is 34. Filtered entries in the BMI field contain values 

greater than 27. 

HIDING AND DISPLAYING DETAILS IN THE LIST 

HIDING AND DISPLAYING ROWS AND COLUMNS 

Analyze the male and female patients’ BMI values based on the results of 

filtration performed in the task in Section 2.7.4 (fig. 51). 

 

=G3>AVERAGE($G$3:$G$14) 
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For this purpose, copy the result of the filtration task in Section 2.7.4 (range 

of cells A36:I40) on the Sheet 3. Rename this sheet as BMI Filter. 

It is more convenient to hide unnecessary information in columns D, E and 

F. To hide the columns, do the following: 

1. Select the group of columns D, E and F. 

2. On the Home tab, in the Cell group, click Format. In the Visibility 

section, select Hide & Unhide  Hide Columns (fig. 23). 

The result is shown in the fig. 51. 

Fig. 51 

 

To display the hidden columns again, do the following: 

1. Select the area of the hidden columns (columns C and G). 

2. On the Home tab, in the Cell group, click Format. 

In the Visibility section, click Hide & Unhide  Unhide Columns. 

The list will return to its original view. 

GROUPING OF ROWS AND COLUMNS 

Combine the records of female patients and hide them, to display only the 

male patients’ records. 

To create a group, do the following: 

1. Select the rows 2 and 3 (the rows that you want to hide). 

2. On the Data tab, in the Outline group, click Group. 

The layout of the list has changed, and its structure has become visible 

(fig. 52). 

Fig.  52 

 

When you click the structure button , all the grouped rows with the 

female patients’ records will become hidden. 

When you click the structure button , the entire list will be displayed. 
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Clicking on the Hide Details button  you will hide the female patients’ 

records. 

Clicking on the Unhide Details button  you will display the details about 

female patients. 

To ungroup the records, do the following: 

1. Select the range of rows 2:3 again. 

2. On the Data tab, in the Outline group, click Ungroup. 

SUMMARIZING 

CREATION OF TOTALS 

Calculate the total number of sorted rows on the BMI Filter sheet. 

Do the following: 

1. Convert the data range A1:I5 into a table. For this purpose do the 

following: 

– click in any data cell, then on the Insert tab, click Table; 

– in the Create Table window that appears, set the following parameters: 

select the range of cells A1:I5 to create a list on its basis and set the check box 

that confirms that the table contains headers; 

– Click OK. 

The data is organized in the form of a table again: the title bars of each 

column have the AutoFilter arrows, a frame selects the range of table cells, the 

lower right corner of the range has the table resizing marker. 

2. To calculate the totals, on the additional tab Table tools/Design in the 

Table Style Options group, set the Total Row check box. 

3. Excel will add the row «Total», which will automatically summarize the 

values in the last column of the list (fig. 53). 

In our example, the last column contains the data that can not be 

summarized (the doctors’ surnames), so Excel will display the value that 

corresponds to the number of column elements. 
 

Fig. 53 

 

This mode allows the user to display automatically the totals for each 

column of the table. 
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To calculate the totals in any column, place the cursor in the Total row of 

the selected column and select the required variant of the final formula from the 

drop-down list. 

4. To disable the Total row, on the additional tab Table tools/Design, clear 

the Total Row check box. 

5. Restore the Total Row. 

CALCULATION OF SUBTOTALS 

CALCULATION OF SUBTOTALS BY ONE FIELD 

Perform calculations based on other columns. For example, calculate the 

number of male and female patients in the initial database. 

For this purpose do the following: 

1. Move to the Sheet4 and rename it as Totals. 

2. Move to the ICMS Database sheet and copy the original database (range 

A1:I14) using the Paste Special, to the Totals sheet. 

3. Since we are going to calculate subtotals by the Gender field, the data in 

this column must be sorted (e.g., in ascending order) before summarizing. For this 

purpose, select any cell in the column C (Gender). 

4. Sort the records of the column in 

alphabetic order. Click the Sort A to Z 

button  to open the AutoFilter drop-

down list, or click the button  on the 

Data tab in the Sort & Filter group. 

5. To make the Totals command 

active, convert the list into a data range: in 

the additional tab Table tools/Design, in 

the Tools group click Convert to range.  

6. On the Data tab, in the Outline 

group, click Subtotal. 

7. In the Subtotal dialog box 

(fig. 54), do the following: 

– in the field At each change in, 

select the column Gender to calculate the 

totals; 

– in the field Use function, select the function Sum to calculate the totals; 

– in the field Add subtotal to, select the column Gender, that contains the 

values you want to sum up; 

– set the check boxes Replace current totals and Summary below data; 

– Click OK. 

Fig.  54 
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The result of summarising is shown in the fig. 55. 

Fig. 55 

 

After adding totals, the layout of the list has changed, and its structure has 

become visible. 

When you click the structure button , all rows of the list will become 

hidden, except for the Total Row. 

When you click the structure button , only the subtotal calculations of the 

patients of each gender will be displayed. 

Clicking on the Unhide Details top button  you will display the details 

about female patients. 

Clicking on the Hide Details button  you will hide the details and show 

only totals again. 

8. Cancel the calculation of subtotals. For this purpose, on the Data tab in 

the Outline group, click Subtotal, and in the Subtotal dialog box, click Remove 

All. 
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